Bug 811121 - katello-headpin cli client command accepts invalid value also --value value
katello-headpin cli client command accepts invalid value also --value value
Status: CLOSED WONTFIX
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.0.0
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Jordan OMara
SAM QE List
:
Depends On:
Blocks: sam11-tracker
  Show dependency treegraph
 
Reported: 2012-04-10 03:58 EDT by Tazim Kolhar
Modified: 2016-04-25 20:54 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-02 21:12:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tazim Kolhar 2012-04-10 03:58:52 EDT
Description of problem:
headpin cli client command, accepts invalid value of
org or environment .
even though such org or environment does not exist

Version-Release number of selected component (if applicable):
[root@ibm-hs22-03 ~]# rpm -qa katello-headpin
katello-headpin-0.1.145-1.el6.noarch


How reproducible:
yum install -y katello-headpin-all

Steps to Reproduce:
1.list the organisation using headpin cli command
2.make client remember a org option with invalid value
3.display saved_options for client
  
Actual results:
[root@ibm-hs22-03 ~]# headpin -u admin -p admin org list
--------------------------------------------------------------------------------
                               Organization List

 Id   Name                              Description                                                
--------------------------------------------------------------------------------
 1    ACME_Corporation                  Red Hat Organization                                       
 2    ibm-hs22-03testorg                                                                           
 3    activationkeyorgmr8Y2qFZDStRZsX   This test org created via  api for QE                       
 4    someorgrAZ7dl76M                  This test org created via api for QE                       
 5    manifestIAY3BiqWiWzb6S0x          This test org created via api for QE                       
 6    manifestwAIin74fJXSwjl3s          This test org created via api for QE                       
 7    manifest-6K7CZGZLDJGd             This test org created via api for QE                       
 8    manifest-omEJ04lqRRP              This test org created via api for QE                       
 9    manifest-bH9ZDbQVXkh              This test org created via api for QE                       
 10   manifest-B52uIk37E9pR             This test org created via api for QE                       
 11   manifest-l4rrlE92N9JIB            This test org created via api for QE                       
 12   Orgpph4YF4hRmxP                   This is a test organization, created by web ui automation  
 14   recreateorgCZFBnhUj               This is a test organization, created by web ui automation  
 15   OrglzP4rPr2                       This is a test organization, created by web ui automation  
 16   vqIEUM5R26vl                      This test org created via api for QE                       
 17   rbHhBozPw0Px                      This test org created via api for QE                       
 18   CdtXbVfu                          This test org created via api for QE                       
 19   zKgSW6A0srwZ                      This test org created via api for QE                       
 20   SearchOrgSW1fXxmW6kwBi            This test org created via api for QE                       
 21   SearchOrgyLJGAAO3G8Fx             This test org created via api for QE                       
 22   SearchOrgrk8ZkgjWeB8vS            This test org created via api for QE                       
 23   SearchOrgV3NetJz1E                This test org created via api for QE                       
[root@ibm-hs22-03 ~]# headpin -u admin -p admin client remember --option org --value testorg
Successfully remembered option [ org ] 
[root@ibm-hs22-03 ~]# headpin -u admin -p admin client saved_options
--------------------------------------------------------------------------------
                                 Saved Options

 Option   Value    
--------------------------------------------------------------------------------
 org      testorg  


Expected results:
here, there is no org named testorg still the command accepted
the value to be remembered by client

Additional info:
Comment 2 RHEL Product and Program Management 2012-04-10 04:04:47 EDT
Thank you for your bug report. This issue was evaluated for inclusion
in the current release of Subscription Asset Manager (SAM). Unfortunately,
we are unable to address this request. Because we are in the final stages
of development in the current release, only significant, release-blocking
issues involving serious regressions and data corruption can be considered.

If you believe this issue meets the release blocking criteria as defined and
communicated to you by your Red Hat Support representative, please ask
your representative to file this issue as a blocker for the current release.
Otherwise, ask that it be evaluated for inclusion in the next release of SAM.
Comment 3 RHEL Product and Program Management 2012-04-10 04:24:42 EDT
Thank you for your bug report. This issue was evaluated for inclusion
in the current release of Subscription Asset Manager (SAM). Unfortunately,
we are unable to address this request. Because we are in the final stages
of development in the current release, only significant, release-blocking
issues involving serious regressions and data corruption can be considered.

If you believe this issue meets the release blocking criteria as defined and
communicated to you by your Red Hat Support representative, please ask
your representative to file this issue as a blocker for the current release.
Otherwise, ask that it be evaluated for inclusion in the next release of SAM.
Comment 4 Lukas Zapletal 2012-05-02 09:41:25 EDT
The "remember" option is "generic" - it works with any parameter and does not check anything. If we add organization check, we can ask - why it does not check product as well (or any other option that works with this). This is nice-to-have.

Note You need to log in before you can comment on or make changes to this bug.