This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 811123 - vncconnect does not work
vncconnect does not work
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
17
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F17Beta/F17BetaBlocker
  Show dependency treegraph
 
Reported: 2012-04-10 04:07 EDT by Hongqing Yang
Modified: 2012-04-10 22:59 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-10 22:59:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
anaconda log (2.92 KB, text/plain)
2012-04-10 04:07 EDT, Hongqing Yang
no flags Details
program log (1.52 KB, text/plain)
2012-04-10 04:07 EDT, Hongqing Yang
no flags Details
syslog (50.99 KB, text/plain)
2012-04-10 04:08 EDT, Hongqing Yang
no flags Details
vncserver log (1.78 KB, text/plain)
2012-04-10 04:09 EDT, Hongqing Yang
no flags Details

  None (edit)
Description Hongqing Yang 2012-04-10 04:07:07 EDT
Created attachment 576418 [details]
anaconda log

Description of problem:
vncconnect does not work with F17 Beta RC4

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. start VM with kernel parameter 'vnc vncconnect=host:port'
2. listen guest with 'vncviewer -listen port'
3. the guest is not connected
  
Actual results:

guest cannot be connected

Expected results:
host can connect with guest successfully.

Additional info:
Comment 1 Hongqing Yang 2012-04-10 04:07:40 EDT
Created attachment 576419 [details]
program log
Comment 2 Hongqing Yang 2012-04-10 04:08:33 EDT
Created attachment 576420 [details]
syslog
Comment 3 Hongqing Yang 2012-04-10 04:09:13 EDT
Created attachment 576421 [details]
vncserver log
Comment 4 Adam Williamson 2012-04-10 12:27:28 EDT
I think this is user error. Tao Wu reported success for the same test on 32-bit and I just tested with 64-bit and it worked fine here. Perhaps you can talk to Tao and see what you did differently?

Note that the test case states "The command vinagre may also be used", but I'm not sure that's right, or if it is, the syntax is different. When I tried to use vinagre it didn't work either. I don't think vinagre actually uses the -listen parameter. Using vncviewer, though, it's fine.

-1 blocker, as seems unreproducible.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 5 Hongqing Yang 2012-04-10 22:59:39 EDT
I try again today and it works, I think this is because the port is occupied by other progress.

Note You need to log in before you can comment on or make changes to this bug.