Bug 811143 - [RHEL6.3 guest] Network can not get the ip after s3 with NetworkManager service start
[RHEL6.3 guest] Network can not get the ip after s3 with NetworkManager servi...
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.3
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Amos Kong
Virtualization Bugs
:
Depends On:
Blocks: 761491
  Show dependency treegraph
 
Reported: 2012-04-10 05:30 EDT by Qunfang Zhang
Modified: 2015-05-24 20:06 EDT (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-21 04:42:40 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Qunfang Zhang 2012-04-10 05:30:38 EDT
Description of problem:
Similar with bug 807967, suspend guest to mem and wakeup it after 5 minutes. Guest failed to get the IP address. If I stop NetworkManager service, can not reproduce any more.

Version-Release number of selected component (if applicable):
Host:
kernel-2.6.32-261.el6.x86_64
qemu-kvm-0.12.1.2-2.270.el6.x86_64
seabios-0.6.1.2-16.el6.x86_64

Guest:
kernel-2.6.32-260.el6.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Boot a guest (without virtio device to avoid bug 803187)

 /usr/libexec/qemu-kvm -M rhel6.3.0 -cpu Conroe -enable-kvm -m 2G -smp 2,sockets=1,cores=2,threads=1 -name rhel6.3 -uuid c1392688-189d-4b8b-a170-a8939dad2d18 -rtc base=localtime,driftfix=slew -drive file=/home/rhel6.3-64.qcow2,if=none,id=drive-virtio-disk0,format=qcow2,cache=none,werror=stop,rerror=stop,aio=native -device ide-drive,bus=ide.0,unit=1,drive=drive-virtio-disk0,id=virtio-disk0 -netdev tap,id=hostnet0,script=/etc/qemu-ifup -device e1000,netdev=hostnet0,id=net0,mac=00:1a:2a:28:18:22,bus=pci.0 -usb -device usb-tablet,id=input0 -boot c -monitor stdio  -drive if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -vnc :10  -qmp tcp:0:4444,server,nowait -chardev socket,path=/tmp/qzhang-test,server,nowait,id=isa1 -device isa-serial,chardev=isa1,id=isa-serial1 

2. Inside guest:
#pm-suspend

3. Wait for 5 minutes.

4. Wakeup guest:
(qemu)system_wakeup

  
Actual results:
Guest failed to get IP address.

Expected results:
Guest should work well and all the devices including NIC device should work.

Additional info:
Stop NetworkManager service and re-test, this issue does not exist.
Comment 2 Qunfang Zhang 2012-04-10 06:00:11 EDT
Update for more clear:
(1) When 'service NetworkManager stop', the guest still has networking because
the 'network' service is up. So in this condition, guest network is always
available. Suspend guest to memory and wakeup it after 5 minutes, guest network
is accessible as well.  

(2) When 'NetworkManager' service starts,  will hit this bug.
Comment 3 Ademar Reis 2012-04-10 17:32:16 EDT
I know this sounds a bit odd, but please confirm that this bug doesn't happen on a non virt (real hardware) rhel6.3 machine (you can probably test this by suspending the host itself).

I have this exact problem on one of my old fedora boxes (a netbook), so this might be a problem unrelated to qemu.
Comment 4 Qunfang Zhang 2012-04-11 02:45:06 EDT
(In reply to comment #3)
> I know this sounds a bit odd, but please confirm that this bug doesn't happen
> on a non virt (real hardware) rhel6.3 machine (you can probably test this by
> suspending the host itself).
> 
> I have this exact problem on one of my old fedora boxes (a netbook), so this
> might be a problem unrelated to qemu.

Hi, Ademar
Just test on host which is installed with the following packages, and this issue does not happen on a host.
install tree:  RHEL6.3-20120329.0/
kernel version: 2.6.32-262.el6.x86_64

Steps:
1. Install the host with the above tree.
2. Check the network. It is available and can ping other host.
And the 'NetworkManager' service is starting.
3. #pm-suspend
4. Wait for 8 minutes.
5. Wakeup host by press the power button. The power button is blinking during suspending to mem. And press it to wakeup system. 

Result: Host resumes from S3 and comes back to the screen before it suspended.
Wait for few seconds the network will come back.
Comment 7 RHEL Product and Program Management 2012-07-10 03:50:33 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 8 RHEL Product and Program Management 2012-07-10 22:05:39 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 10 Amos Kong 2012-10-31 04:32:21 EDT
Talked with mst, reassign this to me.
Comment 11 Amit Shah 2012-12-20 10:06:00 EST
I think this is specific to the network adapters -- I believe this doesn't happen with virtio devices, is that correct?  If so, please adjust summary to note it only happens with e1000.
Comment 12 Qunfang Zhang 2012-12-21 04:34:38 EST
Hi, Amit
I can not reproduce it now on the latest rhel6.4 host even with the same command line in comment 0. Tried all virtio/e1000/rtl8139 nics. Guest can get ip address again after resume with NetworkManager started.
Host:
Install tree: RHEL6.4-20121212.1/
kernel-2.6.32-348.el6.x86_64
qemu-kvm-rhev-0.12.1.2-2.346.el6.x86_64
Comment 13 Amit Shah 2012-12-21 04:42:40 EST
OK - so looks like this one got fixed, then!

Amos, might be worthwhile to check recent commits to e1000 device emulation to see what could've caused this.

Thanks for testing again, closing.

Note You need to log in before you can comment on or make changes to this bug.