Bug 811161 - [virtio-win][viostor]Guest BSOD during S3 with virtio disk
[virtio-win][viostor]Guest BSOD during S3 with virtio disk
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win (Show other bugs)
6.3
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Vadim Rozenfeld
Virtualization Bugs
: Regression
: 811910 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-10 06:12 EDT by Mike Cao
Modified: 2012-06-20 07:58 EDT (History)
7 users (show)

See Also:
Fixed In Version: buil 26
Doc Type: Bug Fix
Doc Text:
No Documentation needed. It was a regression introduced with 810694 bug-fix.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 07:58:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Cao 2012-04-10 06:12:53 EDT
Description of problem:


Version-Release number of selected component (if applicable):
 uname -r
2.6.32-259.el6.x86_64
# rpm -q qemu-kvm
qemu-kvm-0.12.1.2-2.270.el6.x86_64

win2k8R2 guests


How reproducible:
only 1 time during I reproduce 803633

Steps to Reproduce:
1.Start guest with virtio-blk-pci
EG:/usr/libexec/qemu-kvm -M rhel6.3.0 -enable-kvm -m 8G -smp     4,sockets=4,cores=1,threads=1 -name win2k8-R2 -uuid     e2eaca3e-e764-f57b-22f0-74f4ab8c4965 -monitor stdio -rtc     base=localtime,driftfix=slew -device     piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -drive     file=/test/win2k8r2,if=none,id=drive-ide0-0-0,format=raw,cache=none -device   virtio-blk-pci,drive=drive-ide0-0-0,id=ide0-0-0,bootindex=1 -drive     file=/test/en_windows_server_2008_r2_standard_enterprise_datacenter_and_web_with_sp1_x64_dvd_617601.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw     -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -netdev     tap,script=/etc/qemu-ifup,downscript=no,id=hostnet0 -device     rtl8139,netdev=hostnet0,id=net0,mac=52:54:00:15:af:6a,bus=pci.0,addr=0x4     -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=serial0     -device usb-tablet,id=input0 -spice port=5910,disable-ticketing -vga qxl     -device intel-hda,id=sound0,bus=pci.0,addr=0x5 -device virtio-balloon-pci,id=balloon0
2.s3 guest 
3.
  
Actual results:
guest BSOD

Expected results:
Gust still work 

Additional info:
Comment 3 Vadim Rozenfeld 2012-04-14 16:04:28 EDT
*** Bug 811910 has been marked as a duplicate of this bug. ***
Comment 4 Vadim Rozenfeld 2012-04-15 04:33:23 EDT
Hi Mike

The problem should be fixed in build 26 
(just don't forget to run crystal disk mark on it)
http://download.devel.redhat.com/brewroot/packages/virtio-win-prewhql/0.1/26/win/virtio-win-prewhql-0.1.zip

Best regards,
Vadim.
Comment 7 Mike Cao 2012-04-16 04:21:09 EDT
Tried more than 20 times on virtio-win-prewhql-26 and cache=none/writeback both

steps:
1.start VM w/ virtio block
eg:/usr/libexec/qemu-kvm -M rhel6.3.0 -enable-kvm -m 8G -smp 4,sockets=4,cores=1,threads=1 -name win2k8-R2 -uuid e2eaca3e-e764-f57b-22f0-74f4ab8c4965 -monitor stdio -rtc base=localtime,driftfix=slew -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -drive file=/home/win2k8R2,if=none,id=drive-ide0-0-0,format=qcow2,cache=none -device virtio-blk-pci,drive=drive-ide0-0-0,id=ide0-0-0,bootindex=1 -drive file=/root/en_windows_server_2008_r2_standard_enterprise_datacenter_and_web_with_sp1_x64_dvd_617601.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -netdev tap,script=/etc/qemu-ifup,downscript=no,id=hostnet0 -device rtl8139,netdev=hostnet0,id=net0,mac=52:54:00:15:af:6a,bus=pci.0,addr=0x4 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=serial0   -device usb-tablet,id=input0 -spice port=5910,disable-ticketing -vga qxl -device intel-hda,id=sound0,bus=pci.0,addr=0x5 -device virtio-balloon-pci,id=balloon0 -fda /home/virtio-win.vfd 
2.run crystal disk mark in the guest
3.during step2 ,run s3 

Actual Results:
Tried more than 20 times ,guests works fine .

Based on above ,this bug has been fixed ald .
Comment 10 Vadim Rozenfeld 2012-05-03 04:33:55 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No Documentation needed.
It was a regression introduced with 810694 bug-fix.
Comment 11 errata-xmlrpc 2012-06-20 07:58:54 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0751.html

Note You need to log in before you can comment on or make changes to this bug.