Bug 811163 - cryptsetup luksClose - Device foo is busy
Summary: cryptsetup luksClose - Device foo is busy
Status: CLOSED DUPLICATE of bug 809188
Alias: None
Product: Fedora
Classification: Fedora
Component: cryptsetup-luks (Show other bugs)
(Show other bugs)
Version: 16
Hardware: Unspecified Linux
unspecified
low
Target Milestone: ---
Assignee: LVM and device-mapper development team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-04-10 10:15 UTC by Marco Hartgring
Modified: 2012-05-18 13:28 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-10 10:41:47 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Marco Hartgring 2012-04-10 10:15:24 UTC
Description of problem:
After opening and mounting a LUKS volume it's impossible to close it.

Version-Release number of selected component (if applicable):
cryptsetup-luks-1.3.1-3.fc16

How reproducible:
Always

Steps to Reproduce:
1. cryptsetup luksOpen <volume> crypt
2. mount /dev/mapper/crypt
3. umount /dev/mapper/crypt 
4. cryptsetup luksClose -v /dev/mapper/crypt

Actual results:
Closing of the LUKS volume

Expected results:

Device crypt is busy.
Command failed with code 16: Device crypt is busy.

Additional info:
This has been happening a few kernel versions ago, I can't recall exactly when it started.
A reboot will close the volume without problems.

Comment 1 Milan Broz 2012-04-10 10:41:47 UTC

*** This bug has been marked as a duplicate of bug 809188 ***


Note You need to log in before you can comment on or make changes to this bug.