Bug 81119 - Screen is jumbled when coming up after blanking
Screen is jumbled when coming up after blanking
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks: 82784
  Show dependency treegraph
 
Reported: 2003-01-05 00:40 EST by Ken Schar
Modified: 2007-04-18 12:49 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-19 22:48:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Copy of lsmod while nv driver is loaded (1.71 KB, text/plain)
2003-01-15 08:49 EST, Ken Schar
no flags Details
Copy of XF86Config with nv driver loaded (3.22 KB, text/plain)
2003-01-15 08:50 EST, Ken Schar
no flags Details
Copy of XFree86 log from /var/log (33.36 KB, text/plain)
2003-01-15 09:01 EST, Ken Schar
no flags Details

  None (edit)
Description Ken Schar 2003-01-05 00:40:24 EST
Description of problem: When screen blanks after several minutes and you try to
bring screen back up it is shrunk to 1/4 of it's size and sections of screen are
jumbled (eg. - right upper quarter of screen is in lower left, etc.)


Version-Release number of selected component (if applicable):


How reproducible: All screen to go to sleep and blank out.


Steps to Reproduce:
1. Allow screen to blank
2. When you bring screen back up it's jumbled.
3.
    
Actual results: Screen becomes jumbled and shrunken.  Nec. to logout to fix
problem. 


Expected results: Screen should come back up from blanking and still be all in
order and readable.


Additional info: System is a Toshiba Satellite Pro 6100 with a NVidia GeForce 4
card.
Comment 1 Bill Nottingham 2003-01-06 17:26:09 EST
What driver are you using?
Comment 2 Ken Schar 2003-01-06 20:44:30 EST
I have the NVidia GeForce420 Go graphics controller and it's running the "nv"
driver and it's configured with 16mb.

I will try switching to the "vesa" driver and see if I have the same results.


Comment 3 Ken Schar 2003-01-08 22:34:40 EST
I have used with vesa driver for 2 days instead of nv drivers and have not
experienced the same problem.  NV driver is chosen when selecting probe
videocard and card IS a Nvidia GeForce420 Go.  Looks like probs with nv driver.
Comment 4 Mike A. Harris 2003-01-15 07:15:29 EST
Please attach X config file and log file from using the "nv" driver.
Also, while X is running, please provide the output of:

lsmod
Comment 5 Ken Schar 2003-01-15 08:49:14 EST
Created attachment 89373 [details]
Copy of lsmod while nv driver is loaded
Comment 6 Ken Schar 2003-01-15 08:50:42 EST
Created attachment 89374 [details]
Copy of XF86Config with nv driver loaded
Comment 7 Ken Schar 2003-01-15 08:52:51 EST
You mentioned xf86config but you also said log file.  What log file would that be? 
 
Thanks! 
Comment 8 Mike A. Harris 2003-01-15 08:54:28 EST
The X log file in /var/log
Comment 9 Ken Schar 2003-01-15 09:01:02 EST
Created attachment 89375 [details]
Copy of XFree86 log from /var/log

Sorry, I realized this just after I committed that last comment. Here you go!
Comment 10 Mike A. Harris 2003-04-12 12:26:22 EDT
Please test this video card with Red Hat Linux 9 and indicate here if
the problem is resolved or not.
 
If the problem persists, please file a bug report at http://bugs.xfree86.org
which will get to the nv driver maintainer whom works at Nvidia, and add a
link to the URL of your upstream bug report so I can track the issue
upstream and backport any fixes that get made by the maintainer.
 
Thanks.
Comment 11 Ken Schar 2003-04-13 21:30:42 EDT
Yes, this problem still exists in RH9 however now I am able to CTL-ALT-F1 to the
console and then CTL-ALT-F7 back to graphics mode and the screen comes back.

Here is the URL to the bug report at XFree86

http://bugs.xfree86.org/cgi-bin/bugzilla/show_bug.cgi?id=152
Comment 12 Mike A. Harris 2004-04-19 22:48:35 EDT
The upstream 'nv' driver maintainer has closed the upstream bug
as "WONTFIX" indicating this can not be resolved because it requires
ACPI event notification, which does not occur currently.  This issue
would have to be resolved by upstream X development before we could
address it as a feature enhancement in a future release.

Normalized upstream bug URL:
    http://bugs.xfree86.org/show_bug.cgi?id=152

Closing as 'WONTFIX'.

Note You need to log in before you can comment on or make changes to this bug.