Bug 811191 - Missing --attach in the virt-viewer man page
Summary: Missing --attach in the virt-viewer man page
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-viewer
Version: 6.3
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Daniel Berrangé
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-04-10 11:11 UTC by yuping zhang
Modified: 2012-06-20 12:12 UTC (History)
8 users (show)

Fixed In Version: virt-viewer-0.5.2-5.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-06-20 12:12:23 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:0772 0 normal SHIPPED_LIVE virt-viewer bug fix and enhancement update 2012-06-19 20:35:11 UTC

Description yuping zhang 2012-04-10 11:11:38 UTC
Description of problem:
Missing --attach in the virt-viewer man page

Version-Release number of selected component (if applicable):


How reproducible:
virt-viewer-0.5.2-4.el6.x86_64

Steps to Reproduce:
1. virt-viewer --help-all
...
-a, --attach       Attach to the local display using libvirt
...
#man virt-viewer
No content in #man virt-viewer

Comment 2 Daniel Berrangé 2012-04-17 13:54:34 UTC
Fixed upstream

commit ad5d29da5ea586a42e3aafeb2cb54ff15efa68cf
Author: Daniel P. Berrange <berrange@redhat.com>
Date:   Tue Apr 17 12:42:39 2012 +0100

    Add manpage docs for the --attach option

Comment 4 yuping zhang 2012-04-19 02:49:31 UTC
Verified this issue with:
# rpm -q virt-viewer
virt-viewer-0.5.2-5.el6.x86_64

#man virt-viewer
....
       -a, --attach
           Use libvirt to directly attach to a local display, instead of making a TCP/UNIX socket connection. This avoids the need to
           authentication with the remote display, if authentication with libvirt is already allowed.  This option does not work with remote
           displays.
....

So change the bug status to VERIFIED.

Comment 6 errata-xmlrpc 2012-06-20 12:12:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0772.html


Note You need to log in before you can comment on or make changes to this bug.