Bug 811196 - tuned should require python-decorator
tuned should require python-decorator
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: tuned (Show other bugs)
17
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Jan Vcelak
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-10 07:39 EDT by Martin Cermak
Modified: 2013-03-03 20:30 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-10 08:22:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Cermak 2012-04-10 07:39:39 EDT
Description of problem:

  Tuned should require python-decorator. Without decorator, tuned tracebacks:

# service tuned status
Redirecting to /bin/systemctl  status tuned.service
tuned.service - Dynamic System Tuning Daemon
          Loaded: loaded (/usr/lib/systemd/system/tuned.service; disabled)
          Active: failed (Result: exit-code) since Tue, 10 Apr 2012 07:34:01 -0400; 6s ago
         Process: 10642 ExecStart=/usr/sbin/tuned -d (code=exited, status=1/FAILURE)
          CGroup: name=systemd:/system/tuned.service

Apr 10 07:34:01 dhcp-25-124.brq.redhat.com tuned[10642]: Traceback (most recent call last):
Apr 10 07:34:01 dhcp-25-124.brq.redhat.com tuned[10642]: File "/usr/sbin/tuned", line 23, in <module>
Apr 10 07:34:01 dhcp-25-124.brq.redhat.com tuned[10642]: import tuned
Apr 10 07:34:01 dhcp-25-124.brq.redhat.com tuned[10642]: File "/usr/lib/python2.7/site-packages/tuned/__init__.py", line 1, in <module>
Apr 10 07:34:01 dhcp-25-124.brq.redhat.com tuned[10642]: from controller import *
Apr 10 07:34:01 dhcp-25-124.brq.redhat.com tuned[10642]: File "/usr/lib/python2.7/site-packages/tuned/controller.py", line 22, in <module>
Apr 10 07:34:01 dhcp-25-124.brq.redhat.com tuned[10642]: import exports.dbus
Apr 10 07:34:01 dhcp-25-124.brq.redhat.com tuned[10642]: File "/usr/lib/python2.7/site-packages/tuned/exports/dbus.py", line 21, in <module>
Apr 10 07:34:01 dhcp-25-124.brq.redhat.com tuned[10642]: import decorator
Apr 10 07:34:01 dhcp-25-124.brq.redhat.com tuned[10642]: ImportError: No module named decorator


Version-Release number of selected component (if applicable):

  tuned-2.0.1-1.fc17
Comment 1 Jan Vcelak 2012-04-10 08:22:36 EDT
Thank you for the report.

Fixed upstream:
http://git.fedorahosted.org/git/?p=tuned.git;a=commit;h=b23cd44
Comment 2 Fedora Update System 2012-10-22 08:39:33 EDT
tuned-2.0.1-4.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/tuned-2.0.1-4.fc17
Comment 3 Fedora Update System 2012-11-19 22:17:28 EST
tuned-2.0.1-4.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.