Bug 811203 - splitsep() not working correctly
splitsep() not working correctly
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dracut (Show other bugs)
17
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: dracut-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-10 08:14 EDT by Fridtjof Busse
Modified: 2012-04-25 01:03 EDT (History)
2 users (show)

See Also:
Fixed In Version: dracut-018-23.git20120419.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-25 01:03:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fridtjof Busse 2012-04-10 08:14:10 EDT
Description of problem:
After the latest update to the pxeboot/initrd.img (2012-04-08), dracut dies while trying to fetching the installer from the repo and thus breaking PXE installation:
dracut: anaconda fetching installer from http
dracut Warning: can't find installer mainimage path in .treeinfo

The installation worked just fine with the earlier initrd.
The cause seems to be the splitsep function from /lib/dracut-lib.sh used by /lib/dracut/hooks/iniqueue/online/80anaconda-netroot.sh.

A simple testscript using splitsep:
$ ./test.sh  anaconda-net:http://$internal_proxy/download.fedora.redhat.com/fedora/linux/development/17/x86_64/os/
prefix=anaconda-net
repo=http

$repo is thus way too short.

The relevant PXE config looks like this:
initrd=http://$internal_proxy/download.fedora.redhat.com/fedora/linux/development/17/x86_64/os/images/pxeboot/initrd.img lang= vga=791 inst.ks.device=link inst.ks=http://$internal_server/kickstart/datacenter.ks panic=60 sshd noselinux nogpt biosdevname=0 dhcptimeout=5 inst.repo=http://$internal_proxy/download.fedora.redhat.com/fedora/linux/development/17/x86_64/os/

How reproducible:
Try to install Fedora 17 via PXE with a inst.repo parameter.
Comment 1 Fedora Update System 2012-04-16 10:07:51 EDT
dracut-018-12.git20120416.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/dracut-018-12.git20120416.fc17
Comment 2 Fedora Update System 2012-04-16 17:56:12 EDT
Package dracut-018-12.git20120416.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dracut-018-12.git20120416.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-5985/dracut-018-12.git20120416.fc17
then log in and leave karma (feedback).
Comment 3 Fedora Update System 2012-04-19 11:14:30 EDT
dracut-018-23.git20120419.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/dracut-018-23.git20120419.fc17
Comment 4 Fedora Update System 2012-04-19 22:27:57 EDT
Package dracut-018-23.git20120419.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dracut-018-23.git20120419.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-6258/dracut-018-23.git20120419.fc17
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2012-04-25 01:03:59 EDT
dracut-018-23.git20120419.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.