Bug 811219 - ss -ul has no output
Summary: ss -ul has no output
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: iproute
Version: 6.2
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: rc
: ---
Assignee: Petr Šabata
QA Contact: David Spurek
URL:
Whiteboard:
Depends On: 691100
Blocks: 836169 856606
TreeView+ depends on / blocked
 
Reported: 2012-04-10 13:17 UTC by Josh
Modified: 2015-03-02 05:26 UTC (History)
4 users (show)

Fixed In Version: iproute-2.6.32-21.el6
Doc Type: Bug Fix
Doc Text:
Cause Invoking 'ss -ul' didn't list open UDP sockets. Consequence EL ss users couldn't list open UDP sockets. Fix The ss utility was patched to list UDP sockets. Result The ss utility now correctly reports open UDP sockets.
Clone Of:
: 856606 (view as bug list)
Environment:
Last Closed: 2013-02-21 10:23:54 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0417 normal SHIPPED_LIVE iproute bug fix and enhancement update 2013-02-20 20:49:52 UTC

Description Josh 2012-04-10 13:17:10 UTC
Description of problem:
ss does not output listening udp ports

Version-Release number of selected component (if applicable):
2.6.32-17.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1. ss -ul
  
Actual results:
column headings only

Expected results:
output of all listening udp sockets

Additional info:
netstat -ul works properly

Comment 2 Petr Šabata 2012-04-10 16:01:23 UTC
This sounds like bug #691100 to me.

Comment 3 Petr Šabata 2012-05-31 09:59:30 UTC
Josh, could you confirm?

Comment 4 Josh 2012-05-31 11:14:47 UTC
I can confirm that it is the same behavior as that bug, yes.

Comment 5 Petr Šabata 2012-05-31 12:48:15 UTC
Thank you.

Comment 9 Petr Šabata 2012-08-29 15:27:00 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause
    Invoking 'ss -ul' didn't list open UDP sockets.
Consequence
    EL ss users couldn't list open UDP sockets.
Fix
    The ss utility was patched to list UDP sockets.
Result
    The ss utility now correctly reports open UDP sockets.

Comment 16 errata-xmlrpc 2013-02-21 10:23:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0417.html


Note You need to log in before you can comment on or make changes to this bug.