Bug 811226 - libreoffice on ARM is FTBFS
libreoffice on ARM is FTBFS
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: ARMTracker
  Show dependency treegraph
 
Reported: 2012-04-10 09:31 EDT by Peter Robinson
Modified: 2012-05-17 11:12 EDT (History)
7 users (show)

See Also:
Fixed In Version: libreoffice-3.5.3.2-6.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-17 11:12:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Robinson 2012-04-10 09:31:13 EDT
Offending build details at: http://arm.koji.fedoraproject.org/koji/taskinfo?taskID=690747

It looks like there's some ARM specific code paths that might need to be fixed when building on ARM.

Let me know if you want more details or something checked
Comment 1 Caolan McNamara 2012-04-10 09:54:44 EDT
Well, that specific build-failure should be fixed by http://cgit.freedesktop.org/libreoffice/core/commit/?id=4e679ee2501a0babcdce498732d68428d46481e3
Comment 2 Peter Robinson 2012-04-14 04:46:01 EDT
We've another issue with the new build

http://arm.koji.fedoraproject.org/taskinfo?taskID=711532
Comment 3 Caolan McNamara 2012-04-16 10:35:28 EDT
run time failure during the bridge tests. I'd need a working build env to track that down. Do we have a qemu image or something of current arm ? and/or details of the configuration we're targeting hard-float/soft-float that sort of thing ?
Comment 4 Peter Robinson 2012-04-16 10:43:09 EDT
blc: can you provide Caolan access to an internal RH ARM device to enable him to debug libreoffice build issue?
Comment 5 Caolan McNamara 2012-05-17 11:12:35 EDT
libreoffice-3.5.3.2-6.fc17 built for me in the ARM farm, and passed (the minimal) %check

Note You need to log in before you can comment on or make changes to this bug.