Bug 81124 - Kernel Oops on "modprobe ospm_battery".
Kernel Oops on "modprobe ospm_battery".
Status: CLOSED DUPLICATE of bug 80371
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
9
All Linux
medium Severity high
: ---
: ---
Assigned To: Jeff Garzik
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-01-05 01:27 EST by Aleksey Nogin
Modified: 2013-07-02 22:09 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:50:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aleksey Nogin 2003-01-05 01:27:57 EST
In Phoebe 8.0.92 (upgraded from 8.0) on Dell Lattitude C640 I did the following
sequence of modprobe's:

modprobe ospm_processor
modprobe ospm_button
modprobe ospm_adapter
modprobe ospm_battery ospm_ac_adapter

The last modprobe resulted in segfault (and, apparently, a kernel Oops). dmesg
shows:

During boot:

ACPI: Core Subsystem version [20021205]
    ACPI-0263: *** Info: GPE Block0 defined as GPE0 to GPE15
    ACPI-0263: *** Info: GPE Block1 defined as GPE16 to GPE31
ACPI: Subsystem enabled

During modprobes:

Power Resource: found
ACPI: System firmware supports S0 S1 S3 S4 S5
Processor[0]: C0 C1 C2, 8 throttling states
ACPI: Power Button (CM) found
ACPI: Sleep Button (CM) found
ACPI: Lid Switch (CM) found
    ACPI-0189: *** Warning: Buffer created with zero length in AML
Unable to handle kernel NULL pointer dereference at virtual address 00000010
 printing eip:
c0188201
*pde = 00000000
Oops: 0002
ospm_battery ospm_button ospm_processor ospm_system ospm_busmgr nls_iso8859-1
sr_mod i8k speedstep wvlan_cs ds yenta_socket pcmcia_core 3c59x ipt_REJECT iptab
CPU:    0
EIP:    0060:[<c0188201>]    Not tainted
EFLAGS: 00010246

EIP is at acpi_ds_execute_arguments [kernel] 0xd1 (2.4.20-2.2)
eax: 00000000   ebx: 00000000   ecx: c25a1400   edx: dc7ce920
esi: df2ce800   edi: c257fe80   ebp: dc7ce920   esp: d5f979b0
ds: 0068   es: 0068   ss: 0068
Process modprobe (pid: 1947, stackpage=d5f97000)
Stack: df2ce800 00000001 00000000 00000000 00000000 00000000 00000000 00000001
       df3c54a0 df3c54a0 df3c89b4 00000000 c018838d dc7ce920 dc7ce920 00000000
       00000000 dc7ce920 c0193a99 df3c54a0 d5f97a10 00000003 00000000 df3c89b4
Call Trace:   [<c018838d>] acpi_ds_get_buffer_arguments [kernel] 0x3d (0xd5f979e0))
[<c0193a99>] acpi_ex_resolve_node_to_value [kernel] 0xc9 (0xd5f979f8))
[<c0193b2a>] acpi_ex_resolve_to_value [kernel] 0x4a (0xd5f97a1c))
[<c0188d0c>] acpi_ds_resolve_operands [kernel] 0x2c (0xd5f97a30))
[<c0189399>] acpi_ds_exec_end_op [kernel] 0x139 (0xd5f97a48))
[<c0198ed3>] acpi_ps_parse_loop [kernel] 0x553 (0xd5f97a68))
[<c0185de4>] acpi_ut_release_mutex [kernel] 0x74 (0xd5f97a8c))
[<c0185de4>] acpi_ut_release_mutex [kernel] 0x74 (0xd5f97a94))
[<c0185fb7>] acpi_ut_delete_generic_state [kernel] 0x17 (0xd5f97aa4))
[<c01846b8>] acpi_ut_update_object_reference [kernel] 0xb8 (0xd5f97ab0))
[<c0185d45>] acpi_ut_acquire_mutex [kernel] 0x75 (0xd5f97ad0))
[<c01834f5>] acpi_ut_release_to_cache [kernel] 0x45 (0xd5f97ae8))
[<c0185de4>] acpi_ut_release_mutex [kernel] 0x74 (0xd5f97af8))
[<c0199548>] acpi_ps_parse_aml [kernel] 0x1f8 (0xd5f97b18))
[<c018a5b5>] acpi_ds_init_aml_walk [kernel] 0xc5 (0xd5f97b28))
[<c0199fbc>] acpi_psx_execute [kernel] 0x20c (0xd5f97b4c))
[<d5a99104>] .rodata.str1.1 [ospm_battery] 0x0 (0xd5f97b80))
[<c0195968>] acpi_ns_execute_control_method [kernel] 0x58 (0xd5f97b84))
[<c01958eb>] acpi_ns_evaluate_by_handle [kernel] 0xab (0xd5f97b9c))
[<c0195741>] acpi_ns_evaluate_relative [kernel] 0xf1 (0xd5f97bb8))
[<c01846b8>] acpi_ut_update_object_reference [kernel] 0xb8 (0xd5f97be0))
[<d5ae30e4>] .rodata.str1.1 [ospm_busmgr] 0x160 (0xd5f97c00))
[<c0184868>] acpi_ut_remove_reference [kernel] 0x38 (0xd5f97c04))
[<d5a99104>] .rodata.str1.1 [ospm_battery] 0x0 (0xd5f97c10))
[<c0197458>] acpi_evaluate_object [kernel] 0x88 (0xd5f97c18))
[<d5a99104>] .rodata.str1.1 [ospm_battery] 0x0 (0xd5f97c20))
[<d5a99104>] .rodata.str1.1 [ospm_battery] 0x0 (0xd5f97c44))
[<d5ae2ac8>] bm_evaluate_object_R2ecf6ce0 [ospm_busmgr] 0x68 (0xd5f97c48))
[<d5a99104>] .rodata.str1.1 [ospm_battery] 0x0 (0xd5f97c50))
[<d5a980fd>] bt_get_info [ospm_battery] 0x8d (0xd5f97c6c))
[<d5a99104>] .rodata.str1.1 [ospm_battery] 0x0 (0xd5f97c74))
[<d5a983d5>] bt_check_device [ospm_battery] 0x85 (0xd5f97cac))
[<d5a984c1>] bt_add_device [ospm_battery] 0xb1 (0xd5f97cd0))
[<d5a986a2>] bt_notify [ospm_battery] 0x42 (0xd5f97cf0))
[<d5ae142b>] bm_register_driver_R21b2101e [ospm_busmgr] 0x10b (0xd5f97d00))
[<d5a985bb>] bt_initialize [ospm_battery] 0x7b (0xd5f97ec4))
[<d5a98660>] bt_notify [ospm_battery] 0x0 (0xd5f97ed4))
[<d5a986f0>] bt_request [ospm_battery] 0x0 (0xd5f97ed8))
[<d5a99050>] init_module [ospm_battery] 0x50 (0xd5f97f0c))
[<d5a99212>] .rodata.str1.1 [ospm_battery] 0x10e (0xd5f97f10))
[<c011d021>] sys_init_module [kernel] 0x4e1 (0xd5f97f1c))
[<d5a98060>] bt_print [ospm_battery] 0x0 (0xd5f97f20))
[<d5a999d4>] .kmodtab [ospm_battery] 0x0 (0xd5f97f2c))
[<d5a98060>] bt_print [ospm_battery] 0x0 (0xd5f97f58))
[<c01096ff>] system_call [kernel] 0x33 (0xd5f97fc0))

Code: 89 50 10 89 3c 24 e8 e4 1a 01 00 c7 04 24 37 00 00 00 e8 18
Comment 1 Aleksey Nogin 2003-01-05 01:29:10 EST
Sorry, forgot the "ospm_system" at the beginning. The full sequence was:

modprobe ospm_system
modprobe ospm_processor
modprobe ospm_button
modprobe ospm_adapter
modprobe ospm_battery ospm_ac_adapter
Comment 2 Aleksey Nogin 2003-01-05 21:07:40 EST
Just tried "modprobe ospm_battery" straight after booting - same result.
Comment 3 Aleksey Nogin 2003-01-05 21:49:15 EST

*** This bug has been marked as a duplicate of 80371 ***
Comment 4 Red Hat Bugzilla 2006-02-21 13:50:56 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.