Bug 811245 - JDG shows EAP6 child resources
JDG shows EAP6 child resources
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Plugin -- JDG (Show other bugs)
JON 3.0.0
Unspecified Linux
high Severity high
: ---
: JON 3.1.0
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks: 812404
  Show dependency treegraph
 
Reported: 2012-04-10 10:24 EDT by Joel Tosi
Modified: 2016-10-05 19:06 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 812404 (view as bug list)
Environment:
Last Closed: 2012-09-21 14:06:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joel Tosi 2012-04-10 10:24:22 EDT
Description of problem:
I have an EAP6 instance and a JDG standalone instance running.  My agent inventoried my EAP6 instance and when it inventoried the JDG instance, the dashboard shows the JDG instance with the child resources of EAP6 (database pools, JMS, etc) - just that those resources are unavailable.

Version-Release number of selected component (if applicable):
JON plugin-pack tech preview 3.0.1
JON 3
JDG beta (with plugin)


How reproducible:
Verifiable in an environment with EAP6 and JDG running, the issue can be seen in the JON dashboard.

Steps to Reproduce:
1) Install JON 3.0.1 tech preview for EAP 6 plugins
2) Install JDG plugin
3) Startup agent
4) Startup EAP6
5) Verify  EAP6 is inventoried
6) Shutdown EAP6 instance
7) Startup JDG standalone
8) Verify JDG is inventoried
9) In JON browser, expand inventoried JDG instance, not its child resources

Note that I have actually seen it where the status of the EAP6 instance will show up for the status of the JDG instance (available / down) and vice versa.
  
Actual results:
JDG shows child resources that it shouldn't

Expected results:
JDG should only show its relevant resources

Additional info:
Browser was chrome
Comment 1 Charles Crouch 2012-04-13 11:33:52 EDT
Unlinking from RHQ tracker
Comment 2 Larry O'Leary 2012-04-23 12:14:17 EDT
Increasing priority to match upstream bug 812404 and setting target to JON 3.1.0
Comment 3 Ian Springer 2012-05-18 16:19:29 EDT
Joel--

I'm going to need more specifics. Which types of child Resources of the JDG server do you consider irrelevant? Do any of those types correspond to subsystems that JDG could simply not deploy?

Thanks,
Ian
Comment 4 Joel Tosi 2012-05-21 08:52:45 EDT
Hi Ian,
   I honestly haven't looked at the plugin since JDG ER2, but back then it was showing everything from AS7. And this might have been because I had inventoried an AS7 instance first.  

Items that were irrelevant (not installed in ER2 default) that I recall offhand were JDBC pooling and JMS (Queue, Topic).  

But I haven't tried with any more recent builds.

Hope this helps some. I have since torn down that environment.  I can rebuild it if there is something you want me to verify / test.

Best,
Josl
Comment 5 Stefan Negrea 2012-09-21 14:06:24 EDT
The integration between EAP6 plugin and JDG plugin has been fixed for JON 3.1.1. Please reopen this issue if the problem is present.


Relevant bugs that have been resolved recently: bug 820272, bug 826207, bug 825818, and bug 847865.

Note You need to log in before you can comment on or make changes to this bug.