This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 811279 - importing JBossAS 5 server failed to import JVM child properly
importing JBossAS 5 server failed to import JVM child properly
Status: CLOSED NOTABUG
Product: RHQ Project
Classification: Other
Component: Plugins (Show other bugs)
4.4
Unspecified Unspecified
urgent Severity high (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks: jon310-sprint11/rhq44-sprint11
  Show dependency treegraph
 
Reported: 2012-04-10 11:37 EDT by John Mazzitelli
Modified: 2012-04-10 16:44 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-10 16:44:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
screen snapshot of down jvm child resource (73.18 KB, image/png)
2012-04-10 11:37 EDT, John Mazzitelli
no flags Details

  None (edit)
Description John Mazzitelli 2012-04-10 11:37:12 EDT
Created attachment 576496 [details]
screen snapshot of down jvm child resource

I have a JBoss EAP 5.1 server running (it is secured with the user/pass of admin/admin).

I see it in my discovery queue, so I import it.

Everything gets into inventory and and everything is green (I checked the plugin config and it looks like the plugin assumed user/pass is admin/admin as a default, which is why it immediately came in green).

HOWEVER, the child JVM resource is red.  When I look at its plugin configuration, its type is "Java SE 5", not "parent" which is what I think it should be. For example, if I import the RHQ Server (which is really just a JBossAS 4 server), the JVM child comes in green and its type is "parent", NOT Java SE 5, which is what I see the JVM child under my JBoss EAP 5 server).

See attached screen shot.
Comment 1 John Mazzitelli 2012-04-10 11:40:48 EDT
note: we should check if this same thing is broken when importing JBossAS 4 servers. I only tried importing a RHQ Server - which did work, but we should try with a standalone "normal" JBossAS 4 server - not the "special" RHQ Server resource.
Comment 2 John Mazzitelli 2012-04-10 13:34:49 EDT
I just checked and this happens on older RHQ versions as well - so nothing recently broke this - it's been broken.

I see the problem with: RHQ 4.3.0 (build Number: a9b2a27)
Comment 3 John Mazzitelli 2012-04-10 13:37:35 EDT
note: if I go to the JVM child resource's Connection Properties, set Type to "Parent" and unset Connector Address, it goes green and the rest of the JVM's own child resources get discovered, committed to inventory and also go green.
Comment 4 John Mazzitelli 2012-04-10 16:44:52 EDT
OK, after digging into this deeper, I think this can be closed as NOTABUG.

Here's the thing - when I started my EAP instance, I had enabled jmx remoting (that is, I had passed in several of the jmxremote... system properties when starting it up).

That means the EmbeddedJMXServerDiscoveryComponent detected this as a remoted JMX server. There is code that looks to see if it is remoted - and if it is, it sets up the JVM resource with plugin config settings to access it. I then completed the config in the GUI by setting the credentials for my remoted JMX user/pass and it went green.

If it is NOT remoted, it simply sets the plugin configuration "Type" setting to "Parent" and assumes the parent component will handle accessing the MBeanServer.

Note You need to log in before you can comment on or make changes to this bug.