Bug 811293 - rubygem-yard fails %check on F17
rubygem-yard fails %check on F17
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: rubygem-yard (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mo Morsi
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-10 12:10 EDT by Ken Dreyer
Modified: 2014-03-06 07:00 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-06 07:00:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
build.log from koji task #3977330 (49.70 KB, text/x-log)
2012-04-10 12:10 EDT, Ken Dreyer
no flags Details

  None (edit)
Description Ken Dreyer 2012-04-10 12:10:21 EDT
Created attachment 576506 [details]
build.log from koji task #3977330

rubygem-yard fails %check on F17. Commenting out the "rspec spec" line allows the build to succeed in my testing.

Version-Release number of selected component:
rubygem-yard-0.7.4-3.fc17.src.rpm 

My scratch build is at http://koji.fedoraproject.org/koji/taskinfo?taskID=3977328 

I'm attaching build.log in case Koji garbage-collects this file.
Comment 1 Ken Dreyer 2012-04-10 12:24:12 EDT
Sorry, I missed your comment in the .spec about issue #472 upstream. Looks like upstream's fix in 5123ff40c missed version 0.7.5 by one day :(
Comment 2 Vít Ondruch 2012-04-11 03:45:00 EDT
Ken,

Could you please elaborate a bit please? The #472 doesn't look the same as the errors you observed in your scratch build.

I believe you hit [1]. If I remember correctly, last time I was building yard, I did several attempts until I succeeded. Not nice, but I didn't have better solution :/ I did another scratch build now [2] and as you can see, the errors are different.



[1] https://github.com/lsegal/yard/issues/473
[2] http://koji.fedoraproject.org/koji/taskinfo?taskID=3979071
Comment 3 Ken Dreyer 2012-04-11 10:29:53 EDT
You're correct; upstream issue #472 isn't involved here. Even if it was, you're already setting LANG which should have fixed it. Sorry, I was having difficulty distinguishing the various tests in this package :/

I hit this FTBFS issue because I'm rebuilding several gems for EL6, and when I saw this failure there, I wanted to know if it fails on F17 also. I simply ran a scratch build directly out of Fedora's SCM, against the f17 branch.

I'm not sure why you got different errors than I do. I tried building from Fedora's SCM again, this time against the master branch, to see if the F18 environment was the cause. My errors are still different.

http://koji.fedoraproject.org/koji/taskinfo?taskID=3979694
Comment 4 Vít Ondruch 2012-04-12 03:26:30 EDT
The point is every time you run the test it fails differently and sometimes it passes. However, according to #473 I mentioned earlier, it should be already fixed upstream, but I'm not sure it was already released nor I tested it. But if have a time to try with 0.7.5 or eventually backport the patch, please let me know and I'll be glad to release new YARD version.
Comment 5 Ken Dreyer 2012-04-13 14:22:05 EDT
0.7.5 had some test failures, so I rebuilt 0.8.0-master (upstream f3245c565d).

F18: http://koji.fedoraproject.org/koji/taskinfo?taskID=3989089
F16: http://koji.fedoraproject.org/koji/taskinfo?taskID=3989053
F15: http://koji.fedoraproject.org/koji/taskinfo?taskID=3989087

One failed test on F18 and F16:
rspec ./spec/cli/server_spec.rb:184 # YARD::CLI::Server should warn if lockfile is not found (with -G)

Two failed tests on F15 and EL6:
rspec ./spec/cli/server_spec.rb:184 # YARD::CLI::Server should warn if lockfile is not found (with -G)
rspec ./spec/cli/yri_spec.rb:68 # YARD::CLI::Yardoc#run should search for objects and print their documentation

I can open new tickets upstream if you'd like.
Comment 6 Ken Dreyer 2012-04-13 15:14:59 EDT
(In reply to comment #5)
> rspec ./spec/cli/server_spec.rb:184 # YARD::CLI::Server should warn if lockfile
> is not found (with -G)

On F15, when I add rubygem-bundler as a BR, this test does not fail.

https://github.com/lsegal/yard/issues/512
Comment 7 Ken Dreyer 2012-04-13 20:00:21 EDT
(In reply to comment #5)
> rspec ./spec/cli/yri_spec.rb:68 # YARD::CLI::Yardoc#run should search for
> objects and print their documentation

I'm actually seeing this on both F15 and rawhide, so I opened an upstream bug for it as well.

https://github.com/lsegal/yard/issues/513
Comment 8 Fedora End Of Life 2013-04-03 12:24:23 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 19 development cycle.
Changing version to '19'.

(As we did not run this process for some time, it could affect also pre-Fedora 19 development
cycle bugs. We are very sorry. It will help us with cleanup during Fedora 19 End Of Life. Thank you.)

More information and reason for this action is here:
https://fedoraproject.org/wiki/BugZappers/HouseKeeping/Fedora19
Comment 9 Vít Ondruch 2014-03-06 07:00:44 EST
In Fedora, we have YARD 0.8+ which ships some fixes. I hope this issue was already resolved. Please reopen if you still see this issue.

Note You need to log in before you can comment on or make changes to this bug.