Bug 811301 - [ta_IN] skipped translation for msgid "Usage: %s MODULE-NAME [MODULE-OPTIONS] [--help]"
[ta_IN] skipped translation for msgid "Usage: %s MODULE-NAME [MODULE-OPTIONS]...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity low
: beta
: 7.0
Assigned To: candlepin-bugs
Entitlement Bugs
: i18n
Depends On:
Blocks: rhsm-rhel70
  Show dependency treegraph
 
Reported: 2012-04-10 12:25 EDT by John Sefler
Modified: 2014-06-17 20:22 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 06:09:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2012-04-10 12:25:19 EDT
Description of problem:

Version-Release number of selected component (if applicable):
subscription-manager-0.99.13-1.el6.x86_64


How reproducible:


Steps to Reproduce:
[root@jsefler-63server ~]# msgunfmt /usr/share/locale/ta/LC_MESSAGES/rhsm.mo | grep MODULE-NAME -A1
msgid "Usage: %s MODULE-NAME [MODULE-OPTIONS] [--help]"
msgstr "Usage: %s MODULE-NAME [MODULE-OPTIONS] [--help]"

The word "Usage" was not translated by the translator (nor was MODULE-NAME and MODULE-OPTIONS, but that seems to be the a common theme for capitalized words).


Expected results:
msgstr "பயன்பாடு: %s MODULE-NAME [MODULE-OPTIONS] [--help]"
Comment 1 John Sefler 2012-04-10 12:28:09 EDT
[root@jsefler-63server ~]# msgunfmt /usr/share/locale/ta/LC_MESSAGES/rhsm.mo | grep Usage -A1
msgid "Usage"
msgstr "பயன்பாடு"
--
msgid "Usage: %s\n"
msgstr "பயன்பாடு: %s\n"
--
msgid "Usage: %s MODULE-NAME [MODULE-OPTIONS] [--help]"
msgstr "Usage: %s MODULE-NAME [MODULE-OPTIONS] [--help]"

[root@jsefler-63server ~]# 

^^^ Notice that other msgid's containing the word "Usage" were translated.
Comment 2 Hedda Peters 2012-04-12 20:05:21 EDT
Unfortunately, we currently have no resources for ta-IN. 
Unable to fix right now.

Ankit, do you want to keep note of this bug until we have a new ta-IN onboard?
Comment 4 Ankit Patel 2012-05-07 03:01:38 EDT
(In reply to comment #2)
> Unfortunately, we currently have no resources for ta-IN. 
> Unable to fix right now.
> 
> Ankit, do you want to keep note of this bug until we have a new ta-IN onboard?

Yes, we better keep it open until we have a new ta-IN translator onboard!

Thanks!
Ankit
Comment 6 RHEL Product and Program Management 2012-07-10 04:47:45 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 7 RHEL Product and Program Management 2012-07-10 21:48:51 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 8 RHEL Product and Program Management 2012-12-14 03:47:57 EST
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 9 Bryan Kearney 2013-04-18 21:46:53 EDT
All instances of usage seem to be translated in 1.8.6
Comment 10 John Sefler 2013-04-23 13:44:20 EDT
Verifying Version...
[root@jsefler-7 ~]# rpm -q subscription-manager
subscription-manager-1.8.6-1.el7.x86_64

[root@jsefler-7 ~]# msgunfmt /usr/share/locale/ta_IN/LC_MESSAGES/rhsm.mo | grep -i Usage -A1
msgid "Usage"
msgstr "பயன்பாடு"
--
msgid "Usage: %s\n"
msgstr "பயன்பாடு: %s\n"
--
msgid "Usage: %s MODULE-NAME [MODULE-OPTIONS] [--help]"
msgstr "பயன்பாடு: %s MODULE-NAME [MODULE-OPTIONS] [--help]"
--
msgid "usage: %s\n"
msgstr "பயன்பாடு: %s\n"
[root@jsefler-7 ~]# 


Moving to VERIFIED
Comment 11 Ludek Smid 2014-06-13 06:09:18 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.