Bug 811304 - glusterd runs as initrc_t
glusterd runs as initrc_t
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: selinux-policy (Show other bugs)
6.3
All Linux
unspecified Severity medium
: rc
: ---
Assigned To: Miroslav Grepl
Milos Malik
:
Depends On:
Blocks: 832330 870604
  Show dependency treegraph
 
Reported: 2012-04-10 12:35 EDT by Milos Malik
Modified: 2013-02-21 03:35 EST (History)
2 users (show)

See Also:
Fixed In Version: selinux-policy-3.7.19-160.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 870604 (view as bug list)
Environment:
Last Closed: 2013-02-21 03:35:10 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milos Malik 2012-04-10 12:35:38 EDT
Description of problem:


Version-Release number of selected component (if applicable):
selinux-policy-targeted-3.7.19-145.el6.noarch
selinux-policy-doc-3.7.19-145.el6.noarch
selinux-policy-mls-3.7.19-145.el6.noarch
selinux-policy-3.7.19-145.el6.noarch
selinux-policy-minimum-3.7.19-145.el6.noarch

How reproducible:
always

Steps to Reproduce:
# run_init service glusterd status
Authenticating root.
Password: 
glusterd is stopped
# run_init service glusterd start
Authenticating root.
Password: 
Starting glusterd:                                         [  OK  ]
# run_init service glusterd status
Authenticating root.
Password: 
glusterd (pid  11550) is running...
# ps -efZ | grep glusterd
system_u:system_r:initrc_t:s0   root     11550     1  0 18:34 ?        00:00:00 /usr/sbin/glusterd -p /var/run/glusterd.pid
unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 root 11610 10973  0 18:34 pts/0 00:00:00 grep glusterd
# 

Actual results:
* glusterd runs as initrc_t

Expected results:
* glusterd runs in its own SELinux domain
Comment 1 RHEL Product and Program Management 2012-07-10 04:20:03 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 2 RHEL Product and Program Management 2012-07-10 21:55:38 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 3 Miroslav Grepl 2012-09-04 07:33:32 EDT
Added to selinux-policy-3.7.19-160.el6 and made it as unconfined domain.
Comment 6 errata-xmlrpc 2013-02-21 03:35:10 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0314.html

Note You need to log in before you can comment on or make changes to this bug.