Bug 811314 - remote-viewer does not utilize smart card reader plugged when the client is running
remote-viewer does not utilize smart card reader plugged when the client is r...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: nss (Show other bugs)
6.4
Unspecified Linux
medium Severity medium
: beta
: 6.3
Assigned To: Elio Maldonado Batiz
Aleš Mareček
: Reopened
Depends On:
Blocks: 801854 802435 806038 975600
  Show dependency treegraph
 
Reported: 2012-04-10 13:17 EDT by Elio Maldonado Batiz
Modified: 2013-06-18 17:57 EDT (History)
16 users (show)

See Also:
Fixed In Version: nss-3.14.0.0-1.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 806038
: 975600 (view as bug list)
Environment:
Last Closed: 2013-02-21 05:43:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Untested patch to solve the problem (842 bytes, patch)
2012-04-10 17:11 EDT, Bob Relyea
no flags Details | Diff

  None (edit)
Comment 2 Bob Relyea 2012-04-10 17:11:01 EDT
Created attachment 576604 [details]
Untested patch to solve the problem
Comment 3 RHEL Product and Program Management 2012-07-10 02:51:34 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 4 RHEL Product and Program Management 2012-07-10 21:42:59 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 13 Bob Relyea 2012-11-26 13:43:04 EST
Sorry about this, This bug is simply one Elio has cloned to pick up the NSS portion of a bigger fix. The spice fix required changes to coolkey, but the coolkey fix required changes for NSS.

Here's how to reproduct the issue with a smartcard reader.
Make sure coolkey is installed (rpm -q coolkey). if not install it (yum install coolkey)
Make sure pcscd is running (service pcscd status), if not start it (service pcscd restart)

Plug in the smartCard reader.
Start firefox.
Edit->Preferences->Avanced->Encryption->Security Devices->Load
   Module Name: Coolkey
   Module filename: libcoolkeypk11.so
   <OK>
Shutdown firefox.
remove the smartCard reader
Start firefox.
Edit->Preferences->Advanced->Encryption->Security Devices
> Coolkey should be listed without "E-Gate Slot 0 0" if you see "E-Gate Slot 0 0" then Coolkey does not have appropriate patches and you can't test the NSS change.
Insert the reader. 
Insert a card in the reader.
The reader and card should appear in the Security Devices window.

bob
Comment 14 Bob Relyea 2012-11-26 14:16:15 EST
OK, it looks like bug 806038 never got a qa ack from coolkey qa, I've pinged in the bug and changed the owner to me (since the bug isn't in Alon's code). Without that coolkey patch, this bug can't be verified by QA.

bob
Comment 20 errata-xmlrpc 2013-02-21 05:43:34 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0445.html

Note You need to log in before you can comment on or make changes to this bug.