Bug 811316 - reopening guest console not working in rhel 6.2
Summary: reopening guest console not working in rhel 6.2
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-manager
Version: 6.2
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: rc
: ---
Assignee: Cole Robinson
QA Contact: Virtualization Bugs
URL:
Whiteboard:
: 823089 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-04-10 17:28 UTC by jas
Modified: 2012-06-20 12:39 UTC (History)
8 users (show)

Fixed In Version: virt-manager-0.9.0-12.el6
Doc Type: Bug Fix
Doc Text:
Previously, closing and reopening a guest's graphical window would not reopen the graphical console. This was caused by virt-manager incorrectly cleaning up some internal state. virt-manager has been fixed to correctly reopen the graphical console connection.
Clone Of:
Environment:
Last Closed: 2012-06-20 12:39:41 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:0785 0 normal SHIPPED_LIVE virt-manager bug fix and enhancement update 2012-06-19 20:34:46 UTC

Description jas 2012-04-10 17:28:50 UTC
Description of problem:

When running virt-manager on a fully patched RHEL 6.2 system, connecting to a virtual server via ssh, I can connect to guest consoles only once.  After the window is closed, if I try to reopen I get "Connecting to graphical console for guest", and am never connected.  After restarting virt-manager, I can reconnect.

Version-Release number of selected component (if applicable):

0.9.0

Steps to Reproduce:
1. Start up virt-manager on local host, connecting to virtual server via ssh.
2. Double click on virtual guest - see the screen from the guest.
3. Close the window.
4. Try to re-open the window.  You get "Connecting to graphical console for guest" ... never opens.
5. Either close virt-manager, and reopen and it works, or right-click on the virtual server, disconnect, then reconnect.

Expected results:

In 4, re-open the window.

Note -- see the more generalized bug 758225.
I have just freshly kickstarted the client the virtualization server.  Both are running 6.2 with all patches applied.
I don't see other bugs in bugzilla tied specifically to RHEL6.2 which leads me to believe the problem isn't quite widespread?

Comment 2 Cole Robinson 2012-04-16 16:53:44 UTC
Indeed, I can reproduce this on 6.3. This is sufficiently crappy that I'm marking it as a blocker. Fix is already upstream and tested in fedora.

Comment 4 Cole Robinson 2012-04-25 18:54:59 UTC
Fix built in virt-manager-0.9.0-12.el6

Comment 6 Huming Jiang 2012-04-26 06:16:21 UTC
Reproduced it with the following package:
virt-manager-0.9.0-11.el6.x86_64

Verified it with virt-manager-0.9.0-12.el6.x86_64

Steps:
1. Launch virt-manager on local host
2.Connect a hypvisor with ssh: File -> Add connection-> connect a remote host with ssh.
3. Double click on virtual guest
   --> Guest could be opened.
4. Close the guest window.
5. Re-open the guest window. 
   --> Guest could be opened.
6. Close virt-manager, and reopen, or right-click on the
hypervisor, disconnect, then reconnect.
   --> Guest could be opened.

So, move the status to 'verified'.

Comment 7 Cole Robinson 2012-05-28 15:22:16 UTC
*** Bug 823089 has been marked as a duplicate of this bug. ***

Comment 8 Cole Robinson 2012-06-12 15:34:02 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Previously, closing and reopening a guest's graphical window would not reopen the graphical console. This was caused by virt-manager incorrectly cleaning up some internal state. virt-manager has been fixed to correctly reopen the graphical console connection.

Comment 9 German Pulido 2012-06-16 15:22:37 UTC
Hi!

Will this fix be available for RHEL 6.2 Desktop, or should we wait until RHEL 6.3? I use RHEL 6 Desktop on my laptop and the latest virt-manager I am getting is 0.9.0-7

Thanks!

Comment 11 errata-xmlrpc 2012-06-20 12:39:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0785.html


Note You need to log in before you can comment on or make changes to this bug.