Bug 811317 - self heal - dirty afr flags after successfull stat: the symlink one dirty server case
self heal - dirty afr flags after successfull stat: the symlink one dirty ser...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: replicate (Show other bugs)
3.2.6
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Pranith Kumar K
Rahul Hinduja
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-10 13:29 EDT by Rodrigo Severo
Modified: 2013-07-24 13:41 EDT (History)
4 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-24 13:41:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rodrigo Severo 2012-04-10 13:29:13 EDT
Description of problem:
A symlink with dirty flags on one server stats successfully but remain with dirty AFR flags.

Version-Release number of selected component (if applicable):
All this has been tested with Gluster 3.2.6
I mentioned 3.2.5 at "Version(s)" above for the lack of 3.2.6 option on the
dropbox.

How reproducible:
Always

Steps to Reproduce:
1.# getfattr -h -d -m . -e hex /brick/gentoo_estacao_fabrica_amd64-2/app-office/libreoffice-bin-3.3.4.tbz2
getfattr: Removing leading '/' from absolute path names
# file: brick/gentoo_estacao_fabrica_amd64-2/app-office/libreoffice-bin-3.3.4.tbz2
trusted.afr.gentoo_estacao_fabrica_amd64-client-0=0x000000010000000000000000
trusted.afr.gentoo_estacao_fabrica_amd64-client-1=0x000000000000000000000000
trusted.gfid=0xc9f77d2895524829b01268012bdbd65f
2.# getfattr -h -d -m . -e hex /brick/gentoo_estacao_fabrica_amd64-1/app-office/libreoffice-bin-3.3.4.tbz2
getfattr: Removing leading '/' from absolute path names
# file: brick/gentoo_estacao_fabrica_amd64-1/app-office/libreoffice-bin-3.3.4.tbz2
trusted.afr.gentoo_estacao_fabrica_amd64-client-0=0x000000000000000000000000
trusted.afr.gentoo_estacao_fabrica_amd64-client-1=0x000000000000000000000000
trusted.gfid=0xc9f77d2895524829b01268012bdbd65f
3.# stat /mnt/temp/app-office/libreoffice-bin-3.3.4.tbz2
  File: `/mnt/temp/app-office/libreoffice-bin-3.3.4.tbz2' -> `../All/libreoffice-bin-3.3.4.tbz2'
  Size: 33              Blocks: 8          IO Block: 131072 symbolic link
Device: 16h/22d Inode: 18446744073104408160  Links: 1
Access: (0777/lrwxrwxrwx)  Uid: (    0/    root)   Gid: (    0/    root)
Access: 2012-02-24 09:56:01.212502000 -0200
Modify: 2012-02-24 09:57:18.621062000 -0200
Change: 2012-02-24 13:19:25.254840478 -0200
 Birth: -
  
Actual results:
AFR flags remain dirty after successfull stat.

Expected results:
Cleaned AFR flags

Additional info:
This might be a duplicate of bug #811244 and of bug #811250, please advise.
This might be related to the stat-prefetch issue mentioned by Jeff Darcy at
https://bugzilla.redhat.com/show_bug.cgi?id=764232#c14
Comment 1 Amar Tumballi 2012-07-11 01:07:49 EDT
Rodrigo, Can you please try with 3.3.0 version and see if it still happens?
Comment 2 Vijay Bellur 2012-07-25 18:02:47 EDT
CHANGE: http://review.gluster.com/3724 (cluster/afr: Perform data self-heal for non regular files) merged in master by Anand Avati (avati@redhat.com)

Note You need to log in before you can comment on or make changes to this bug.