Bug 811321 - koan --replace-self keeps LANG=<locale> on boot line, breaks F17 installer
koan --replace-self keeps LANG=<locale> on boot line, breaks F17 installer
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: cobbler (Show other bugs)
17
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: James C.
Fedora Extras Quality Assurance
abrt_hash:c595e1bcc6c8d8bc91dc26d434f...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-10 13:38 EDT by Orion Poplawski
Modified: 2012-06-06 08:30 EDT (History)
7 users (show)

See Also:
Fixed In Version: 2.2.3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-06 08:30:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb-U_YzrD (219.17 KB, text/plain)
2012-04-10 13:38 EDT, Orion Poplawski
no flags Details

  None (edit)
Description Orion Poplawski 2012-04-10 13:38:07 EDT
libreport version: 2.0.8
cmdline:        /usr/bin/python  /usr/sbin/anaconda
executable:     /usr/sbin/anaconda
exnFileName:    /tmp/anaconda-tb-U_YzrD
hashmarkername: anaconda
kernel:         3.3.0-1.fc17.i686
other involved packages: 
product:        Fedora
reason:         Error: unsupported locale setting
release:        Cannot get release name.
time:           Tue 10 Apr 2012 05:36:41 PM UTC
version:        17

anaconda-tb-U_YzrD: Text file, 224434 bytes

description:
:The following was filed automatically by anaconda:
:anaconda 17.18 exception report
:Traceback (most recent call first):
:  File "/usr/lib/python2.7/locale.py", line 531, in setlocale
:    return _setlocale(category, locale)
:  File "/usr/lib/python2.7/site-packages/scdate/core/zonetab.py", line 85, in __translate_tz
:    locale.setlocale(locale.LC_ALL, "")
:  File "/usr/lib/python2.7/site-packages/scdate/core/zonetab.py", line 127, in _set_tz
:    self.__translate_tz()
:  File "/usr/lib/python2.7/site-packages/scdate/core/zonetab.py", line 59, in __init__
:    self.tz = tz.replace ('_', ' ')
:  File "/usr/lib/python2.7/site-packages/scdate/core/zonetab.py", line 218, in readZoneTab
:    entry = ZoneTabEntry (code, lat, long, tz, comments)
:  File "/usr/lib/python2.7/site-packages/scdate/core/zonetab.py", line 153, in __init__
:    self.readZoneTab (fn)
:  File "/usr/lib/python2.7/site-packages/pyanaconda/kickstart.py", line 1161, in execute
:    tab = zonetab.ZoneTab()
:  File "/usr/lib/python2.7/site-packages/pyanaconda/kickstart.py", line 1332, in execute
:    obj.execute()
:  File "/usr/lib/python2.7/site-packages/pyanaconda/kickstart.py", line 1383, in doKickstart
:    anaconda.ksdata.execute()
:  File "/usr/lib/python2.7/site-packages/pyanaconda/dispatch.py", line 383, in dispatch
:    self.dir = self.steps[self.step].target(self.anaconda)
:  File "/usr/lib/python2.7/site-packages/pyanaconda/gui.py", line 88, in return_false
:    func(*args, **kwargs)
:Error: unsupported locale setting

environ:
:LC_NUMERIC=C
:LVM_SUPPRESS_FD_WARNINGS=1
:GCONF_GLOBAL_LOCKS=1
:PATH=/usr/bin:/bin:/sbin:/usr/sbin:/mnt/sysimage/bin:/mnt/sysimage/usr/bin:/mnt/sysimage/usr/sbin:/mnt/sysimage/sbin:/sbin:/usr/sbin
:PIXMAPPATH=/tmp/updates/pixmaps/:/tmp/updates/:/tmp/product/pixmaps/:/tmp/product/:pixmaps/:/usr/share/anaconda/pixmaps/:/usr/share/pixmaps/:/usr/share/anaconda/:/usr/share/python-meh/:/usr/share/icons/Fedora/48x48/apps/
:HOME=/tmp
:DISPLAY=:1
:LANG=en_US.UTF-8
:TERM=linux
:XAUTHORITY=/root/.Xauthority
:GLADEPATH=/tmp/updates/:/tmp/updates/data/ui/:ui/:/usr/share/anaconda/ui/:/usr/share/python-meh/
:SHLVL=0
:LIBUSER_CONF=/tmp/libuser.JQEO6s
:GNOME_DISABLE_CRASH_DIALOG=1
:KEYTABLE=us
:SYSFONT=True
:ksdevice=link
:PYTHONPATH=/tmp/updates
:BOOT_IMAGE=/boot/vmlinuz
:ks=http://cobbler.cora.nwra.com/cblr/svc/op/ks/system/athena
:PWD=/
:MALLOC_PERTURB_=204
:MALLOC_CHECK_=2
Comment 1 Orion Poplawski 2012-04-10 13:38:10 EDT
Created attachment 576528 [details]
File: anaconda-tb-U_YzrD
Comment 2 Orion Poplawski 2012-05-04 16:39:13 EDT
I'm still seeing this with 17.TC2 with a koan --replace-self install.  I'm setting repo=.... to get the 17.TC2 squashfs.img.  Does koan need to be setting something (or removing something) on the kernel boot line?
Comment 3 Orion Poplawski 2012-05-04 16:44:03 EDT
Bah, looks like it was the lang= line which is coming from koan.  Re-assigning.
Comment 4 Orion Poplawski 2012-05-04 16:51:53 EDT
Nope, removing the lang= line doesn't help.  There is a LANG=en_US.UTF-8 entry and that's what causing it.  Removing it works.
Comment 5 James C. 2012-05-21 20:24:14 EDT
This has been addressed in the following github issue:

https://github.com/cobbler/cobbler/pull/180

Version 2.2.3 koan will introduce the --no-copy-default option, which will prevent the copying of the options from the current default kernel. Additionally, you can remove the "lang: ~" option from the kernel_options setting in /etc/cobbler/settings to prevent that option from being added in the future.
Comment 6 James C. 2012-06-06 08:30:59 EDT
2.2.3-1 has been released, which resolves this bug.

Note You need to log in before you can comment on or make changes to this bug.