Bug 811327 - RFE: enable ipv6 TUI
RFE: enable ipv6 TUI
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.4
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Joey Boggs
Virtualization Bugs
: FutureFeature
Depends On: 911398
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-10 13:50 EDT by Mike Burns
Modified: 2014-01-21 14:15 EST (History)
12 users (show)

See Also:
Fixed In Version: ovirt-node-3.0.1-2.el6
Doc Type: Enhancement
Doc Text:
The manager is having support for ipv6 added, so there was a need to expose the ipv6 functionality into the TUI. The IPv6 function is enabled in the TUI, and the NIC can get IPv6 addresses - already available in version: rhev-hypervisor6-6.5-20131017.0.iso.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 14:15:29 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Burns 2012-04-10 13:50:58 EDT
Description of problem:
RHEV-M is adding support for ipv6, so we need to expose the ipv6 functionality into the TUI

Version-Release number of selected component (if applicable):
6.4
Comment 1 Mike Burns 2012-06-12 13:32:42 EDT
acathrow -- when is support for ipv6 landing in rhev-m?
Comment 2 RHEL Product and Program Management 2012-07-10 03:19:19 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 3 RHEL Product and Program Management 2012-07-10 21:48:08 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 4 Mike Burns 2012-07-11 10:20:06 EDT
acathrow -- nudge?
Comment 5 Dave Allan 2012-07-12 16:20:01 EDT
Should we ignore the rhev-m dependency?  If not, is there a BZ against rhev-m?
Comment 6 Mike Burns 2012-07-12 16:27:56 EDT
(In reply to comment #5)
> Should we ignore the rhev-m dependency?  If not, is there a BZ against
> rhev-m?

From rhev-h/ovirt-node perspective, the code is there already, just disabled for ipv6.  We disabled specifically for RHEV-M because they don't support it.  

I don't know of a bug against RHEV-M which is why I'm asking acathrow.
Comment 8 Mike Burns 2013-02-14 17:33:57 EST
Some additional notes with 6.5 due to the new TUI

Enable the ipv6 UI in the new TUI
If possible make it a section that can be hidden from view if the layered product does not support it (some value set at installation time).
Comment 9 Mike Burns 2013-06-10 16:13:37 EDT
Let's do what is said in Comment 6:

* Have UI available for IPv6
* provide some method for an LP to disable
Comment 19 wanghui 2013-10-11 23:10:43 EDT
Test version:
rhev-hypervisor6-6.5-20130930.0.auto665.el6.iso
ovirt-node-3.0.1-3.el6.noarch

Test steps:
1. Clean install .
2. Go to the Network page and configure NIC with IPv6.
3. Input DNS server with ipv6 address.

Test results:
1. The IPv6 function is enabled in TUI. And the NIC can got IPv6 address already.

So the IPv6 function is already in TUI. So this bug is fixed in rhev-hypervisor6-6.5-20130930.0.auto665.el6.iso. I will recheck it when I got official build.

For the detail functions of IPv6, I would like to track them using detail bugs as the followings #985345, #981264, #981296, #991296, #981279, #1008795, #1008841.
Comment 20 wanghui 2013-10-18 07:11:37 EDT
According to comments#19, I have recheck this feature in the following version.

Test version:
rhev-hypervisor6-6.5-20131017.0.iso
ovirt-node-3.0.1-4.el6.noarch

Test steps:
1. Clean install rhev-hypervisor6-6.5-20131017.0.iso.
2. Go to the Network page and configure NIC with IPv6.
3. Input DNS server with ipv6 address.

Test results:
1. The IPv6 function is enabled in TUI. And the NIC can got IPv6 address already.

The IPv6 function is already in TUI. This bug is fixed in rhev-hypervisor6-6.5-20131017.0.iso. So change the bug's status from ON_QA to VERIFIED.

For the detail functions of IPv6, I would like to track them using detail bugs as the followings #985345, #981264, #981296, #991296, #981279, #1008795, #1008841.
Comment 23 Cheryn Tan 2013-11-07 19:33:35 EST
This bug is currently attached to errata RHBA-2013:15277. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 26 errata-xmlrpc 2014-01-21 14:15:29 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0033.html

Note You need to log in before you can comment on or make changes to this bug.