Bug 811331 - Update to the icewm-clearlooks theme
Update to the icewm-clearlooks theme
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: icewm (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Gilboa Davara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-10 14:05 EDT by Marcus Moeller
Modified: 2012-11-23 03:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-18 21:27:40 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
updated icewm-clearlooks theme (42.84 KB, application/x-gzip)
2012-04-10 14:06 EDT, Marcus Moeller
no flags Details
clearlooks 1.3.7-7 (30.23 KB, image/png)
2012-11-06 12:16 EST, Marcus Moeller
no flags Details
updated clearlooks 20121106 (30.08 KB, image/png)
2012-11-06 12:16 EST, Marcus Moeller
no flags Details
latest version of the Clearlooks theme for icewm 20121106 (34.53 KB, application/x-gzip)
2012-11-06 12:17 EST, Marcus Moeller
no flags Details

  None (edit)
Description Marcus Moeller 2012-04-10 14:05:48 EDT
Description of problem:

With the current icewm clearlooks theme, the window buttons are a bit too near by the screen edge in maximized window mode.

I have updated the theme, by replacing the window control buttons and adjusting TitleBarHeight to 21. 

It would be great if you could include the modified version of the theme.
Comment 1 Marcus Moeller 2012-04-10 14:06:39 EDT
Created attachment 576538 [details]
updated icewm-clearlooks theme
Comment 2 Gilboa Davara 2012-06-14 02:55:17 EDT
I'll free some time to work on it.
(I was thinking about improving the look and feel of icewm - time for refresh?)

Thanks.
- Gilboa
Comment 3 Marcus Moeller 2012-06-14 03:10:30 EDT
If you like, you might take a look at the Neon Theme, I have recently made:

http://box-look.org/content/show.php/Neon?content=151167

I could also provide a version with a Red Hat/Fedora menu icon.
Comment 4 Gilboa Davara 2012-06-14 09:25:02 EDT
I was searching box-look for something that either matches Fedora-XFCE / Fedora-GNOME or Fedora-KDE look.

- icewm-oxygen is semi-ok.
http://box-look.org/content/show.php/OxyAya?content=136242

- Couldn't find icewm-adwaita (gnome).

- Couldn't find icewm-nodoka (xfce).

As it stands, its either keeping clearlooks + fixes or moving to oxygen.
Either way, I'll only added another package (icewm-XXX) and keep icewm-clearlooks.

- Gilboa
Comment 5 Marcus Moeller 2012-06-14 09:30:22 EDT
I would then just stay with the modified clearlooks
Comment 6 Marcus Moeller 2012-09-04 16:16:06 EDT
Do you think you could update the package containing the improved version of the clearlooks theme?

It would also be great to finally switch from bluecurve to gnome-icon-theme.
Comment 7 Gilboa Davara 2012-09-12 11:49:25 EDT
I'll free some time to get it done ASAP.

- Gilboa
Comment 8 Gilboa Davara 2012-11-06 05:04:38 EST
1.3.7-7 will be pushed later today.
Thanks again for the report (and sorry for long duration).

- Gilboa
Comment 9 Fedora Update System 2012-11-06 05:50:53 EST
icewm-1.3.7-7.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/icewm-1.3.7-7.fc17
Comment 10 Fedora Update System 2012-11-06 05:51:18 EST
icewm-1.3.7-7.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/icewm-1.3.7-7.fc16
Comment 11 Fedora Update System 2012-11-06 05:51:43 EST
icewm-1.3.7-7.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/icewm-1.3.7-7.fc18
Comment 12 Marcus Moeller 2012-11-06 12:15:21 EST
My version of clearlooks has been improved in other aspects in the meanwhile. The panel height is no longer displayed correctly in Fedora 18. Also the Fedora vendor logo has been improved.

Please take a look at the latest version I have attached and at the screenshots to show the difference.
Comment 13 Marcus Moeller 2012-11-06 12:16:06 EST
Created attachment 639470 [details]
clearlooks 1.3.7-7
Comment 14 Marcus Moeller 2012-11-06 12:16:53 EST
Created attachment 639472 [details]
updated clearlooks 20121106
Comment 15 Marcus Moeller 2012-11-06 12:17:34 EST
Created attachment 639473 [details]
latest version of the Clearlooks theme for icewm 20121106
Comment 16 Marcus Moeller 2012-11-06 12:19:26 EST
I have noticed that the panel height also seems to be related to the logo you have included. So you just could replace the fedora logo, with the one in my package.
Comment 17 Fedora Update System 2012-11-06 13:53:44 EST
Package icewm-1.3.7-7.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing icewm-1.3.7-7.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-17702/icewm-1.3.7-7.fc18
then log in and leave karma (feedback).
Comment 18 Fedora Update System 2012-11-18 21:27:42 EST
icewm-1.3.7-7.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 19 Fedora Update System 2012-11-18 21:31:04 EST
icewm-1.3.7-7.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 20 Fedora Update System 2012-11-23 03:10:17 EST
icewm-1.3.7-7.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.