Bug 811333 - [RFE] [ipa webui] Allow UI to manage Kerberos Tickey Policy on a per user basis
[RFE] [ipa webui] Allow UI to manage Kerberos Tickey Policy on a per user basis
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Martin Kosek
IDM QE LIST
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-10 14:06 EDT by Namita Soman
Modified: 2016-02-19 06:57 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-19 06:57:59 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Namita Soman 2012-04-10 14:06:40 EDT
Description of problem:
The UI now has a section to display the Kerberos Ticket Policy for a user (bug 783291) But no way to set it in  UI for the user.
Using CLI, admin can manage/modify the kerberos ticket policy for a user -
ipa krbtpolicy-mod --maxlife=99999 user1



Version-Release number of selected component (if applicable):
ipa-server-2.2.0-8.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1. In UI - go to Identity - Users - go to the user's details, and there is the kerberos ticket policy
2. Go to Policy - Kerberos Ticket Policy

  
Actual results:
There is no way to manage it for a user

Expected results:
Since CLI allows it, User details displays it, provide a way in UI to manage it for the user as well. 

Additional info:
Comment 3 Martin Kosek 2012-04-11 03:43:37 EDT
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/2249
Comment 5 Martin Kosek 2016-02-19 06:57:59 EST
Thank you taking your time and submitting this request for Red Hat Enterprise Linux. The request was cloned to the upstream tracker long time ago (see link to the upstream ticket above), but it was unfortunately not given a priority neither in the upstream project, nor in Red Hat Enterprise Linux.

Given that this request is not planned for a close release, it is highly unlikely it will be fixed in this major version of Red Hat Enterprise Linux. We are therefore closing the request as WONTFIX.

To request that Red Hat reconsiders the decision, please reopen the Bugzilla with the help of Red Hat Customer Service and provide additional business and/or technical details about it's importance to you. Please note that you can still track this request or even offer help in the referred upstream Trac ticket to expedite the solution.

Note You need to log in before you can comment on or make changes to this bug.