Bug 811340 - Select First Product in My Installed Software table by Default
Select First Product in My Installed Software table by Default
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Alex Wood
Entitlement Bugs
:
Depends On:
Blocks: 771748 827225
  Show dependency treegraph
 
Reported: 2012-04-10 14:24 EDT by Matt Reid
Modified: 2013-01-07 22:49 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
No documentation needed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 22:49:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Reid 2012-04-10 14:24:43 EDT
Description of problem:
We do not select a product beforehand for users from the table, they must click on one themselves to see additional information. However, not all users recognized that the products in the table were clickable and they could see more information. I think we should pre-select the first entry in the table for them to help alleviate any potential confusion. That way whenever they see the My Installed Software tab, they clearly see a row selected and more information displayed below the table. At that point, they know that they can select other products in the table (if there are any).

Version-Release number of selected component (if applicable):
subscription-manager-1.0.0-1.git.9.fc486b4
Comment 1 RHEL Product and Program Management 2012-04-11 08:18:34 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 2 Alex Wood 2012-04-17 14:29:35 EDT
commit 80a76455d7113c9d30cbeb8176ae3650f0d1cfe7
Author: Alex Wood <awood@redhat.com>
Date:   Fri Apr 13 12:59:23 2012 -0400

    811340: Select the first product in My Installed Software table by default.
Comment 4 spandey 2012-06-13 08:24:54 EDT
Verified using following rpm on rhel5.9 machine 

subscription-manager-gui-1.0.3-1.git.30.db0f648.el5
subscription-manager-migration-1.0.3-1.git.30.db0f648.el5
subscription-manager-migration-data-1.11.1.1-1.git.2.c7fbafe.el5
subscription-manager-firstboot-1.0.3-1.git.30.db0f648.el5
subscription-manager-1.0.3-1.git.30.db0f648.el5


Working as expected ,first product is by default selected in My installed Software table.

Resolving defect as verified
Comment 6 errata-xmlrpc 2013-01-07 22:49:48 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html

Note You need to log in before you can comment on or make changes to this bug.