Bug 811353 - python.i686 binary not installed on x86_64 system
python.i686 binary not installed on x86_64 system
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: python (Show other bugs)
16
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Dave Malcolm
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-10 15:11 EDT by Renato Botelho
Modified: 2013-04-12 10:56 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-10 15:41:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Renato Botelho 2012-04-10 15:11:39 EDT
Description of problem:
I need to use python i686 on a Fedora x86_64 system. I already have python.x86_64 installed and working fine, so, i've installed python.i686 to my system, it installed fine so i understand both packages can coexist.

The problem is both packages install /usr/bin/python, i noted python.i686 didn't overwritten 64-bit python binary, what is good, but, i cannot use 32-bit python. IMHO it should install the binary with a different name, like python-32.

Version-Release number of selected component (if applicable):
python-2.7.2-5.2.fc16

How reproducible:
Always

Steps to Reproduce:
1. Install python.x86_64
2. Install python.i686
3. Try to use 32-bit python
  
Actual results:


Expected results:


Additional info:
Comment 1 Ignacio Vazquez-Abrams 2012-04-10 15:41:29 EDT
rpm binary coloring will make the x86_64 binary *always* take precedence over the i686 binary. Plus, there could be issues with external C modules. You'll need to build it from source using an alternate prefix.
Comment 2 Stephane List 2013-04-12 10:44:38 EDT
Could you give, just a few hits on how to build it ?

Thanks 

Stephane
Comment 3 Stephane List 2013-04-12 10:56:01 EDT
I've found it on CentOS, and it works.
http://mirror.centos.org/centos/6/os/i386/Packages/python-2.6.6-36.el6.i686.rpm

Note You need to log in before you can comment on or make changes to this bug.