Bug 811368 - Fedora 17 cannot connect to PEAP using AR242x / AR542x Wireless Network Adapter
Fedora 17 cannot connect to PEAP using AR242x / AR542x Wireless Network Adapter
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-10 16:05 EDT by lionghostshop
Modified: 2012-04-17 10:11 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-17 10:11:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/messages (110.95 KB, application/x-bzip)
2012-04-10 16:45 EDT, lionghostshop
no flags Details

  None (edit)
Description lionghostshop 2012-04-10 16:05:09 EDT
Description of problem:


Version-Release number of selected component (if applicable):

3.3.1-3.fc17.x86_64

How reproducible:


Steps to Reproduce:
1. Connect to PEAP
2.
3.
  
Actual results:
Cannot connect

Expected results:
connect

Additional info:
In fedora 16, AR242x / AR542x works. However, I tried new fedora. it does not work.

[leo@localhost ~]$ lspci 
00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 07)
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:03.0 Communication controller: Intel Corporation Mobile 4 Series Chipset MEI Controller (rev 07)
00:03.3 Serial controller: Intel Corporation Mobile 4 Series Chipset AMT SOL Redirection (rev 07)
00:19.0 Ethernet controller: Intel Corporation 82567LM Gigabit Network Connection (rev 03)
00:1a.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 03)
00:1a.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 2 (rev 03)
00:1c.2 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 3 (rev 03)
00:1c.3 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 4 (rev 03)
00:1c.4 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 5 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 93)
00:1f.0 ISA bridge: Intel Corporation ICH9M-E LPC Interface Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation ICH9M/M-E SATA AHCI Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 03)
03:00.0 Ethernet controller: Atheros Communications Inc. AR242x / AR542x Wireless Network Adapter (PCI-Express) (rev 01)
04:00.0 Memory controller: Intel Corporation Turbo Memory Controller (rev 11)
15:00.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev ba)
15:00.1 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller (rev 04)
15:00.2 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 21)
15:00.4 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter (rev 11)
15:00.5 System peripheral: Ricoh Co Ltd xD-Picture Card Controller (rev 11)
Comment 1 Josh Boyer 2012-04-10 16:15:57 EDT
(In reply to comment #0)
> Additional info:
> In fedora 16, AR242x / AR542x works. However, I tried new fedora. it does not
> work.

Which kernel version of Fedora 16?  Both releases are based on the 3.3.1 kernel now, so the drivers should be the same.
Comment 2 lionghostshop 2012-04-10 16:21:35 EDT
I think the version is the same since I have updated fedora 16 before changing to 17. Or it can be other component's bug?
Comment 3 John W. Linville 2012-04-10 16:37:53 EDT
Can we see the contents of /var/log/messages?
Comment 4 lionghostshop 2012-04-10 16:45:29 EDT
Created attachment 576597 [details]
/var/log/messages

I cannot connect to sMobileNet, which uses PEAP.
Comment 5 lionghostshop 2012-04-11 01:37:22 EDT
I've tried WiFi Link 5100, TP-link,  AR242x / AR542x. None of them work in Fedora 17.
Comment 6 John W. Linville 2012-04-12 10:57:45 EDT
Looks like IPv4 configuration is succeeding and IPv6 configuration is failing.  Can you set NetworkManager to ignore IPv6 and try again?  Is is something like "Edit Connections", select the wireless network, find the IPv6 tab, and set Method to "Ignore"...

Once you ignore IPv6, does the connection succeed?
Comment 7 lionghostshop 2012-04-12 11:07:49 EDT
It still failed. 
Please be noted that I also submitted a bug in https://bugzilla.redhat.com/show_bug.cgi?id=811447.
You can find logs from wpa_supplant and dmesg
Comment 8 lionghostshop 2012-04-17 05:31:26 EDT
It works now using follow versions of software components

kernel-3.3.2-1.fc17.x86_64.
NetworkManager-0.9.4.0-1.git20120328.fc17.x86_64
wpa_supplicant-1.0-0.2.fc17.x86_64

The key step is
I downgrade from wpa_supplicant-1.0-0.3.fc17.x86_64 wpa_supplicant-1.0-0.2.fc17.x86_64.

This is suggested in https://bugzilla.redhat.com/show_bug.cgi?id=811447
Comment 9 John W. Linville 2012-04-17 10:11:57 EDT
OK, sounds like the problem is with wpa_supplicant.  I'm closing this as NOTABUG (against the kernel) for now...

Note You need to log in before you can comment on or make changes to this bug.