Bug 811370 - Add proper Requires to all dependencies.
Add proper Requires to all dependencies.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Krzysztof Daniel
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-10 16:09 EDT by Andrew Overholt
Modified: 2014-01-12 19:26 EST (History)
8 users (show)

See Also:
Fixed In Version: eclipse-4.2.0-0.11.I201204051114.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-18 19:11:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
stack trace (12.70 KB, text/plain)
2012-04-10 16:09 EDT, Andrew Overholt
no flags Details

  None (edit)
Description Andrew Overholt 2012-04-10 16:09:29 EDT
Created attachment 576583 [details]
stack trace

Description of problem:
Window -> Open Perspective -> Other -> Planning fails to load Planning perspective

Version-Release number of selected component (if applicable):
$ rpm -qa | grep eclipse
eclipse-platform-4.2.0-0.9.I201204051114.fc18.x86_64
eclipse-mylyn-docs-wikitext-3.7.0-1.fc18.noarch
tomcat5-jasper-eclipse-5.5.31-3.fc15.noarch
eclipse-mylyn-context-cdt-3.7.0-1.fc18.noarch
eclipse-mylyn-context-3.7.0-1.fc18.noarch
eclipse-mylyn-3.7.0-2.fc18.noarch
eclipse-swt-4.2.0-0.9.I201204051114.fc18.x86_64
maven-eclipse-plugin-2.8-5.fc16.noarch
eclipse-egit-1.3.0-1.fc18.noarch
eclipse-mylyn-tasks-trac-3.7.0-1.fc18.noarch
eclipse-rse-3.3.1-1.fc18.noarch
eclipse-mylyn-commons-3.7.0-6.fc18.noarch
eclipse-mylyn-tasks-web-3.7.0-1.fc18.noarch
eclipse-emf-core-2.8.0-0.9.I201204051114.fc18.x86_64
eclipse-jgit-1.3.0-1.fc18.noarch
eclipse-mylyn-builds-hudson-3.7.0-1.fc18.noarch
icu4j-eclipse-4.4.2.2-11.fc18.noarch
eclipse-mylyn-context-pde-3.7.0-1.fc18.noarch
eclipse-pde-4.2.0-0.9.I201204051114.fc18.x86_64
eclipse-mylyn-versions-git-3.7.0-1.fc18.noarch
eclipse-mylyn-versions-3.7.0-1.fc18.noarch
eclipse-emf-2.8.0-0.5.postM6.fc18.noarch
eclipse-mylyn-context-java-3.7.0-1.fc18.noarch
eclipse-rcp-4.2.0-0.9.I201204051114.fc18.x86_64
eclipse-mylyn-builds-3.7.0-1.fc18.noarch
eclipse-jdt-4.2.0-0.9.I201204051114.fc18.x86_64
eclipse-mylyn-docs-htmltext-3.7.0-1.fc18.noarch
eclipse-mylyn-tasks-bugzilla-3.7.0-1.fc18.noarch
eclipse-mylyn-context-team-3.7.0-1.fc18.noarch
eclipse-mylyn-ide-3.7.0-1.fc18.noarch
eclipse-cdt-8.0.1-5.fc18.x86_64
eclipse-mylyn-versions-cvs-3.7.0-1.fc18.noarch

How reproducible:
Always

Steps to Reproduce:
1. Window -> Open Perspective -> Other -> Planning
  
Actual results:
No UI change, blow stack trace on console.

Expected results:
Possible to switch to Mylyn perspectives

Additional info:

1. I'm on F-16 x86_64 (OpenJDK 7) but with rawhide packages
2. CDT perspectives are usable
3. mylyn bundles *are* present in ~/.eclipse/.../bundles.info
4. Stack trace on console attached
Comment 1 Krzysztof Daniel 2012-04-11 06:33:06 EDT
Shortened stacktrace:
org.eclipse.core.runtime.CoreException: Plug-in org.eclipse.mylyn.tasks.ui was unable to load class org.eclipse.mylyn.internal.tasks.ui.PlanningPerspectiveFactory.
Caused by: org.eclipse.core.runtime.internal.adaptor.EclipseLazyStarter$TerminatingClassNotFoundException: An error occurred while automatically activating bundle org.eclipse.mylyn.tasks.ui (363).
Caused by: org.osgi.framework.BundleException: The activator org.eclipse.mylyn.internal.tasks.ui.TasksUiPlugin for bundle org.eclipse.mylyn.tasks.ui is invalid
Caused by: java.lang.NoClassDefFoundError: org/eclipse/mylyn/monitor/ui/IUserAttentionListener
Caused by: org.eclipse.core.runtime.internal.adaptor.EclipseLazyStarter$TerminatingClassNotFoundException: An error occurred while automatically activating bundle org.eclipse.mylyn.monitor.ui (356).
Caused by: org.osgi.framework.BundleException: Exception in org.eclipse.mylyn.internal.monitor.ui.MonitorUiPlugin.start() of bundle org.eclipse.mylyn.monitor.ui.
Caused by: java.lang.LinkageError: loader constraint violation in interface itable initialization: when resolving method "org.eclipse.core.internal.plugins.PluginDescriptor.getPlugin()Lorg/eclipse/core/runtime/Plugin;" the class loader (instance of org/eclipse/osgi/internal/baseadaptor/DefaultClassLoader) of the current class, org/eclipse/core/internal/plugins/PluginDescriptor, and the class loader (instance of org/eclipse/osgi/internal/baseadaptor/DefaultClassLoader) for interface org/eclipse/core/runtime/IPluginDescriptor have different Class objects for the type or.getPlugin()Lorg/eclipse/core/runtime/Plugin; used in the signature
Comment 2 Krzysztof Daniel 2012-04-11 06:54:02 EDT
The same stacktrace cut short:
java.lang.LinkageError (differences between what version of PluginDescriptor.getPlugin  org.eclipse.monitor.ui requires to run and what is actually loaded) cause the perspective to be unavailable at runtime (it is declared, but cannot be switched on). 

I am investigating the cause.
Comment 3 Krzysztof Daniel 2012-04-11 08:34:07 EDT
Andrew, 
could you look for duplicated plugins in your installation? Specifically for org.eclipse.core.runtime*. I can't imagine a situation where singletons cause such a situation.
Comment 4 Andrew Overholt 2012-04-11 08:50:44 EDT
I used uniq -D and see no dupes in /usr/{share,lib64}/eclipse nor in my ~/.eclipse/.../bundles.info or ~/.eclipse.
Comment 5 Krzysztof Daniel 2012-04-11 09:07:49 EDT
plugins may have different qualifiers.
Comment 6 Andrew Overholt 2012-04-11 09:42:39 EDT
(In reply to comment #5)
> plugins may have different qualifiers.

Oops :)  I ran the following and got nothing interesting as output:

find /usr/{share,lib,lib64}/eclipse ~/.eclipse -exec "basename" "{}" ";"| sed "s/_.*//" | uniq -D

cat ~/.eclipse/org.eclipse.platform_4.2.0_793567567/configuration/org.eclipse.equinox.simpleconfigurator/bundles.info|sed "s/_.*//" | uniq -D
Comment 7 Andrew Overholt 2012-04-11 10:21:32 EDT
eclipse-rcp:  /usr/lib64/eclipse/plugins/org.eclipse.core.runtime_3.8.0.v20120308-2101.jar
eclipse-platform:  /usr/lib64/eclipse/plugins/org.eclipse.core.runtime.compatibility_3.2.200.v20120308-2101.jar
Comment 8 Andrew Overholt 2012-04-11 12:02:56 EDT
After upgrading a bunch of dependencies to their rawhide versions, things work!  These are the packages that I upgraded:

  Updating   : tomcat-servlet-3.0-api-7.0.27-2.fc18.noarch                 1/25 
  Updating   : tomcat-jsp-2.2-api-7.0.27-2.fc18.noarch                     2/25 
  Updating   : sac-1.3-12.fc17.noarch                                      3/25 
  Updating   : xml-commons-apis-1.4.01-6.fc17.noarch                       4/25 
  Updating   : tomcat-el-2.2-api-7.0.27-2.fc18.noarch                      5/25 
  Updating   : lucene-2.9.4-8.fc17.noarch                                  6/25 
  Installing : jai-imageio-core-1.2-0.7.20100217cvs.fc17.x86_64            7/25 
  Updating   : batik-1.8-0.1.svn1230816.fc18.noarch                        8/25 
  Updating   : batik-squiggle-1.8-0.1.svn1230816.fc18.noarch               9/25 
  Updating   : lucene-contrib-2.9.4-8.fc17.noarch                         10/25 
  Updating   : tomcat-lib-7.0.27-2.fc18.noarch                            11/25 
  Updating   : apache-commons-el-1.0-23.fc17.noarch                       12/25 
  Updating   : 1:jakarta-commons-httpclient-3.1-7.fc17.noarch             13/25
Comment 9 Krzysztof Daniel 2012-04-11 12:36:50 EDT
do you remember what was the old versions?
Comment 10 Krzysztof Daniel 2012-04-11 12:38:20 EDT
If not, I will put minimum require versions to all dependencies. This can save a lot of problems.
Comment 11 Andrew Overholt 2012-04-11 14:26:34 EDT
Here are the old and new versions of everything I updated:

apache-commons-el-1.0-22.fc15.noarch                 
                  1.0-23.fc17.noarch                 

batik-1.7-12.fc16.noarch                              
      1.8-0.1.svn1230816.fc18.noarch                 

batik-squiggle-1.7-12.fc16.noarch                    
               1.8-0.1.svn1230816.fc18.noarch        

jai-imageio-core-1.2-0.7.20100217cvs.fc17.x86_64     

lucene-2.9.4-7.fc16.noarch                            
       2.9.4-8.fc17.noarch                            

lucene-contrib-2.9.4-7.fc16.noarch                   
               2.9.4-8.fc17.noarch                   

sac-1.3-11.fc16.noarch                                
    1.3-12.fc17.noarch                                

tomcat-lib-7.0.26-1.fc16.noarch                      
           7.0.27-2.fc18.noarch                      

xml-commons-apis-1.4.01-4.fc16.noarch                
                 1.4.01-6.fc17.noarch                

tomcat-jsp-2.2-api-7.0.26-1.fc16.noarch              
                   7.0.27-2.fc18.noarch              
tomcat-servlet-3.0-api-7.0.26-1.fc16.noarch          
                       7.0.27-2.fc18.noarch          
tomcat-el-2.2-api-7.0.26-1.fc16.noarch               
                  7.0.27-2.fc18.noarch               
jakarta-commons-httpclient-1:3.1-5.fc16.noarch       
                           1:3.1-7.fc17.noarch
Comment 12 Fedora Update System 2012-04-12 05:32:43 EDT
eclipse-4.2.0-0.11.I201204051114.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/eclipse-4.2.0-0.11.I201204051114.fc17
Comment 13 Fedora Update System 2012-04-13 02:10:40 EDT
Package eclipse-4.2.0-0.11.I201204051114.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing eclipse-4.2.0-0.11.I201204051114.fc17'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-5765/eclipse-4.2.0-0.11.I201204051114.fc17
then log in and leave karma (feedback).
Comment 14 Fedora Update System 2012-04-18 19:11:08 EDT
eclipse-4.2.0-0.11.I201204051114.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.