Bug 811383 - Add user or group window invisible
Add user or group window invisible
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: system-config-users (Show other bugs)
17
i686 Linux
unspecified Severity low
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-10 17:04 EDT by Piscium
Modified: 2012-05-02 00:40 EDT (History)
4 users (show)

See Also:
Fixed In Version: system-config-users-1.2.115-1.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-02 00:40:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Piscium 2012-04-10 17:04:03 EDT
Description of problem:

If at the first boot screen, at the stage of creating the first user, I click on Advanced, and then click on Add Group, the Add Group window is invisible as it is placed behind the User Manager Window. The same happens with the Add User window (though not always).

Version-Release number of selected component (if applicable):

Beta-RC3, LXDE spin.

How reproducible:

Add Group window - always
Add User window - sometimes (other times the window gets place at the top left corner in which case it is visible.

Actual results:

Invisible window (which looks like the program hang because nothing happened after clicking the button).

Expected results:

Add Group or User window visible.

Additional info:

I started the shell, ran "ps" and openbox was not running. Should it? Openbox is the window manager used by LXDE. Adam Williamson suggested in the Test mailing list that a window manager not running could cause this type of issue. On the other hand the windows did have an X at the top right corner and a title bar, so maybe another window manager was running instead of openbox?
Comment 1 Martin Gracik 2012-04-17 09:12:32 EDT
This is caused by the set_type_hint call in mainWindow.py __init__() method
Comment 2 Nils Philippsen 2012-04-18 08:37:54 EDT
I can't think of an easy way to fix this cleanly:

- Currently, we abuse the window hints to avoid the main window being minimizable. This has the side-effect of additional windows being under the main window (this bug).

- There's no obvious way to only disable minimization via gtk/gdk. Apparently there's a way to do it in X11 directly, but that seems rather over-engineered -- it'd need a new dependency on x11 python module packages or something like that. And it would mean dealing with X11 directly.

- Simply deminimize a window after it's minimized. Flickery perhaps, but effective.

I plan to implement the last option.
Comment 3 Nils Philippsen 2012-04-18 12:44:39 EDT
commit 6aa19b2802211df6ab7a17ca2b45716d0fc5b029
Author:     Nils Philippsen <nils@redhat.com>
AuthorDate: Wed Apr 18 18:20:12 2012 +0200

    firstboot: don't abuse window hints, consolidate code (#811383)
Comment 4 Fedora Update System 2012-04-18 13:07:29 EDT
system-config-users-1.2.115-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/system-config-users-1.2.115-1.fc17
Comment 5 Fedora Update System 2012-04-18 18:11:10 EDT
Package system-config-users-1.2.115-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing system-config-users-1.2.115-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-6096/system-config-users-1.2.115-1.fc17
then log in and leave karma (feedback).
Comment 6 Piscium 2012-04-21 06:36:57 EDT
Issue fixed, thanks. Added karma.
Comment 7 Fedora Update System 2012-05-02 00:40:07 EDT
system-config-users-1.2.115-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.