Bug 811389 - EFI LiveUSB doesn't boot on UEFI system
Summary: EFI LiveUSB doesn't boot on UEFI system
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: livecd-tools
Version: 17
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Brian Lane
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: F17-accepted, F17FinalFreezeExcept
TreeView+ depends on / blocked
 
Reported: 2012-04-10 21:26 UTC by Jared Smith
Modified: 2012-05-04 17:44 UTC (History)
12 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2012-05-04 17:44:40 UTC


Attachments (Terms of Use)

Description Jared Smith 2012-04-10 21:26:55 UTC
Description of problem:

I've created a LiveUSB using livecd-iso-to-disk with the --efi flag, but it won't boot on my UEFI laptop.  After a bit of trying, I was able to boot if I removed the "findiso" command from the ISOLINUX configuration.

Version-Release number of selected component (if applicable):

Fedora 17 Beta RC4 Live image, x86_64

How reproducible:

Always


Steps to Reproduce:
1. Download the Fedora 17 Beta RC4 Live x86_64 image
2. Run "livecd-iso-to-disk --format --reset-mbr --unencrypted-home --noverify --efi /home/user/ISO/Fedora-17-Beta-x86_64-Live-Desktop.iso /dev/sdg1", replacing the path and device with your actual path and device.
3. Boot on a UEFI machine.
  
Actual results:

You'll get an error message from ISOLINUX that something along the lines of Error 15, file not found

Expected results:

Boot from the LiveUSB stick.

Additional info:

Press enter to see the menu, press 'e' on the first line to edit the entry, press 'd' on the line that says 'findiso' to delete that line, and then press 'b' to boot, and it boots!

Tests performed on an Thinkpad X220 with UEFI set in the BIOS to *only* boot UEFI. 

I'm proposing as a NTH for F17 beta, even though I'm not sure that working LiveUSB media is an actual criterion.  Feel free to kick me to the curb if it's not considered important enough.

Comment 1 Brian Lane 2012-04-10 21:48:29 UTC
What version of livecd-tools were you using? > =17.6 and >= 16.11 remove findiso from the config file. If you were using the latest stable from F16 could you try 16.11 from testing and leave feedback on it here - https://admin.fedoraproject.org/updates/FEDORA-2012-3066/livecd-tools-16.11-1.fc16

Comment 2 Tim Flink 2012-04-10 22:07:33 UTC
I just made a bootable live USB with the Fedora 17 beta RC4 x86_64 live desktop media and livecd-tools 16.11.

My uEFI system booted it (as EFI) without issue. Added karma since I didn't realize that I was using livecd-tools that was still in updates-testing.

Comment 3 Adam Williamson 2012-04-11 00:57:00 UTC
ah, I also couldn't reproduce, and comment #1 might be why.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 4 Jared Smith 2012-04-11 01:08:36 UTC
I made the initial test with livecd-tools 16.10.  Testing now with 16.11.  I will report back here (and give karma!) if that fixes things.

Comment 5 Jared Smith 2012-04-11 01:49:11 UTC
16.11 definitely solved the problem.  I've added karma to the package in updates-testing.

Comment 6 Kamil Páral 2012-04-12 12:08:41 UTC
Beta is out, moving to F17 Final NTH

Comment 7 Fedora Update System 2012-04-12 22:31:07 UTC
livecd-tools-16.11-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/FEDORA-2012-3066/livecd-tools-16.11-1.fc16

Comment 8 Fedora Update System 2012-04-13 21:35:04 UTC
livecd-tools-16.11-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Adam Williamson 2012-05-04 17:44:40 UTC
Should have been closed by Bodhi, per comment #8.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers


Note You need to log in before you can comment on or make changes to this bug.