Bug 811395 - virt-inspector to detect ia64 Windows 2k3 install media
virt-inspector to detect ia64 Windows 2k3 install media
Status: CLOSED UPSTREAM
Product: Virtualization Tools
Classification: Community
Component: libguestfs (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard W.M. Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-10 17:41 EDT by Daniel Berrange
Modified: 2012-11-30 08:19 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-30 08:19:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Daniel Berrange 2012-04-10 17:41:30 EDT
Description of problem:
I have a Win2k3 ISO image, which is for ia64 architecture

 en_windows_server_2003_enterprise_64bit.iso

virt-inspector fails to detect it

# guestfish -a ./win2k3/ga/en_windows_server_2003_enterprise_64bit.iso

Welcome to guestfish, the libguestfs filesystem interactive shell for
editing virtual machine filesystems.

Type: 'help' for help on commands
      'man' to read the manual
      'quit' to quit the shell

><fs> run
 100% ⟦▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓⟧ 00:00
><fs> mount /dev/vda /
><fs> ls /ia64
...
txtsetup.sif
...


Version-Release number of selected component (if applicable):
libguestfs-1.17.19-1.fc17.i686

How reproducible:
Always

Steps to Reproduce:
1.# virt-inspector ./win2k3/ga/en_windows_server_2003_enterprise_64bit.iso
2.
3.
  
Actual results:
<?xml version="1.0"?>
<operatingsystems/>

Expected results:
<?xml version="1.0"?>
<operatingsystems>
  <operatingsystem>
    <root>/dev/sda</root>
    <name>windows</name>
    <arch>ia64</arch>
    ...
  </operatingsystem>
</operatingsystems>


Additional info:
Comment 1 Richard W.M. Jones 2012-04-10 18:06:16 EDT
Currently detection of ISO media is broken.  The plan is
to fix this using isoinfo plus some sort of libosinfo mapping
which isn't yet worked out.

To this end there is this bug:
https://bugzilla.redhat.com/show_bug.cgi?id=805417

plus we added isoinfo functions to libguestfs:
https://github.com/libguestfs/libguestfs/commit/a43f35f5bb7c40b000083cd8be5cb1f28595a3f1
Comment 2 Richard W.M. Jones 2012-11-30 08:14:09 EST
This bug was misfiled under the wrong 'Product' so it
wasn't really on my radar.

Since we added support for the libosinfo database, this
should just work.  The libosinfo database does contain
some ia64 ISO image data, and there seems to be at least
one entry for a Win2k3 ia64 ISO.  Of course I have no idea
or way of testing if it works.

So I guess this should either be marked fixed, or the
component changed to libosinfo.  What do you think?
Comment 3 Daniel Berrange 2012-11-30 08:18:07 EST
The libosinfo data will be for the iso I mentioned in the first comment, so lets assume this is fixed
Comment 4 Richard W.M. Jones 2012-11-30 08:19:36 EST
Closed per comment 3.

Note You need to log in before you can comment on or make changes to this bug.