Bug 811399 - baobab does not always skip ntfs symlinks/Junction Points
baobab does not always skip ntfs symlinks/Junction Points
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: baobab (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rui Matos
Fedora Extras Quality Assurance
:
Depends On: 849332
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-10 17:58 EDT by Simon Peeters
Modified: 2012-09-04 18:57 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-04 18:57:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Simon Peeters 2012-04-10 17:58:28 EDT
Description of problem:
when i let baobab scan a windows 7 partition it keeps getting into infinite loops because of some symlinks.

Version-Release number of selected component (if applicable):
3.4.0

How reproducible:
always

Steps to Reproduce:
1. let baobab scan an ntfs partition with this special kind of symlink
2.
3.
  
Actual results:
baobab follows the symlink

Expected results:
baobab skips the symlink

Additional info:
there is something special about this kind of symlinks,
stat reports that it is a symlink, but that it has 2 links, which is the only difference I see from the normal symlinks
Comment 1 Erik van Pienbroek 2012-08-18 09:00:49 EDT
This bug is caused by a bug in the ntfs-3g package.

A bugreport was filed upstream and they've already proposed a patch which resolves this issue: http://tuxera.com/forum/viewtopic.php?f=2&t=29578

I just filed a ticket to the ntfs-3g maintainer in Fedora asking to apply this patch in the Fedora ntfs-3g package: bug 849332
Comment 2 Fedora Update System 2012-08-24 14:45:50 EDT
ntfs-3g-2012.1.15-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/FEDORA-2012-12279/ntfs-3g-2012.1.15-3.fc17
Comment 3 Fedora Update System 2012-09-04 18:57:03 EDT
ntfs-3g-2012.1.15-3.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.