Bug 811403 - kernel panic on shutdown of i686 system with dmraid
kernel panic on shutdown of i686 system with dmraid
Status: CLOSED DUPLICATE of bug 831634
Product: Fedora
Classification: Fedora
Component: dracut (Show other bugs)
17
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: dracut-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-10 18:56 EDT by Tim Flink
Modified: 2012-06-29 10:09 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-29 10:09:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Flink 2012-04-10 18:56:45 EDT
I'm using a fresh install of Fedora 17 beta RC4 i686 on a bare metal machine using a 2 disk RAID1 device through dmraid and a promise RAID controller.

When I attempt to shut the machine down, it attempts to detach the dm devices before giving up and attempting to move on.

Just after giving up, I see the following error message:
shutdown: line 11: /lib/dracut-lib.sh: No such file or directory
  Kernel panic - not syncing: Attempted to kill init!
  panic occurred, switching back to text console

I'm still gathering data on what exactly is going on here. Will update the bug as I learn more.
Comment 1 Harald Hoyer 2012-06-07 06:34:49 EDT
Please try:

https://admin.fedoraproject.org/updates/FEDORA-2012-8927/dracut-018-52.git20120605.fc17

# yum --enablerepo=updates-testing update dracut
# dracut -f
Comment 2 Roman Kagan 2012-06-19 03:05:52 EDT
Dup of bug 831634?
Comment 3 Chris Travers 2012-06-23 11:06:25 EDT
the updates-testing version of dracut fixed the problem for me.
Comment 4 Cole Robinson 2012-06-29 10:09:02 EDT

*** This bug has been marked as a duplicate of bug 831634 ***

Note You need to log in before you can comment on or make changes to this bug.