Bug 811404 - generate Yum .repo file for distro tree in each lab
generate Yum .repo file for distro tree in each lab
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: web UI (Show other bugs)
0.9
Unspecified Unspecified
unspecified Severity unspecified (vote)
: 0.9.1
: ---
Assigned To: Dan Callaghan
: FutureFeature
: 541287 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-10 19:06 EDT by Dan Callaghan
Modified: 2012-07-19 20:38 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-19 20:38:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Callaghan 2012-04-10 19:06:33 EDT
As of version 0.9, Beaker has enough information about each distro tree to be able to generate a Yum .repo file containing all the repos for a given distro tree in a given lab. This would be useful for development and testing. We could link to it from the Distro Tree page.
Comment 1 Dan Callaghan 2012-06-06 20:23:04 EDT
*** Bug 541287 has been marked as a duplicate of this bug. ***
Comment 2 Dan Callaghan 2012-07-06 02:34:15 EDT
On Gerrit: http://gerrit.beaker-project.org/1182

The patch adds a new table "Download Yum Config" under the "Repos" tab on the distro tree page. There is a row for each lab controller, with a link to a .repo file defining all the repos using URLs from that lab's mirror.
Comment 6 Jeff Burke 2012-07-16 09:30:57 EDT
Dan,
 I looked at a few of the distros. Navigated to the repo tab. For example:
https://beaker-stage.engineering.redhat.com/distrotrees/yum_config/28239/RHEL5.9-Server-20120715.0.n-x86_64.repo?lab=lab-stage-03.rhts.eng.bos.redhat.com

The change looks good.

Thank you!
Jeff
Comment 8 Jeff Burke 2012-07-17 14:09:44 EDT
Ignore that previous comment it was for a different BZ. But luck has it I did verify this one as well.
Comment 9 Dan Callaghan 2012-07-19 20:38:35 EDT
Beaker 0.9.1 has been released.

Note You need to log in before you can comment on or make changes to this bug.