Bug 811428 - "iscsiadm --version" providing incorrect version string compare to rpm -q
Summary: "iscsiadm --version" providing incorrect version string compare to rpm -q
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: iscsi-initiator-utils
Version: 6.3
Hardware: All
OS: Linux
unspecified
low
Target Milestone: rc
: ---
Assignee: Chris Leech
QA Contact: Bruno Goncalves
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-04-11 02:54 UTC by Gris Ge
Modified: 2013-02-21 10:31 UTC (History)
4 users (show)

Fixed In Version: iscsi-initiator-utils-6.2.0.873-1.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-02-21 10:31:59 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0438 normal SHIPPED_LIVE iscsi-initiator-utils bug fix and enhancement update 2013-02-20 20:48:28 UTC

Description Gris Ge 2012-04-11 02:54:02 UTC
Description of problem:
"iscsiadm --version" are missing the main version "6."
If this is historical issue and won't fix. let me know.

======
[fge@RHEL6-Stable ~]$ rpm -q iscsi-initiator-utils
iscsi-initiator-utils-6.2.0.872-41.el6.x86_64
#                     ^^^^^^^^^
[fge@RHEL6-Stable ~]$ iscsiadm --version
iscsiadm version 2.0-872.41.el6
#                ^^^^^^^
======


Version-Release number of selected component (if applicable):
iscsi-initiator-utils-6.2.0.872-41.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. iscsiadm --version 
2. rpm -q iscsi-initiator-utils
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Mike Christie 2012-04-11 03:07:26 UTC
Ah yeah, I guess I should add it. The iscsiadm --version values (minus the .el) is from upstream. The 6 in the rpm versioning was just for the rpm/redhat specific versioning. But I guess if we have the .el6 in there we should add the rest.

Comment 2 Suzanne Yeghiayan 2012-05-18 20:54:07 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 4 Bruno Goncalves 2012-10-24 07:04:29 UTC
"iscsiadm --version" now shows the main version number, 6 in this case:

iscsiadm --version
iscsiadm version 6.2.0-873.2.el6

rpm -q iscsi-initiator-utils
iscsi-initiator-utils-6.2.0.873-2.el6.x86_64

Comment 6 errata-xmlrpc 2013-02-21 10:31:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0438.html


Note You need to log in before you can comment on or make changes to this bug.