Bug 811456 - yum update of cups and cups-libs causes all printers to disappear and errors in systemd
Summary: yum update of cups and cups-libs causes all printers to disappear and errors ...
Status: CLOSED DUPLICATE of bug 807672
Alias: None
Product: Fedora
Classification: Fedora
Component: cups
Version: 16
Hardware: Unspecified
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-04-11 06:27 UTC by Peter Glassenbury
Modified: 2012-04-16 10:32 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2012-04-16 10:32:23 UTC


Attachments (Terms of Use)

Description Peter Glassenbury 2012-04-11 06:27:35 UTC
Description of problem:
All our printers disappeared from print selection in applications...
on ALL machines in our department (a week ago)
but was still working on old F14 that haven't been upgraded to F16 yet.
Google found one other person that had the exact same problem -- yesterday
http://www.linux-archive.org/community-support-fedora-users-users-lists-fedoraproject-org/654430-systemd-cups-service-not-working.html
Since found it was not "just me" have tried a downgrade and printing is back

Version-Release number of selected component (if applicable):
      1.5.2-6 of cups and cups-lib has the problem

# yum downgrade cups cups-libs
Loaded plugins: auto-update-debuginfo, langpacks, presto, refresh-packagekit, security
Resolving Dependencies
--> Running transaction check
---> Package cups.x86_64 1:1.5.0-16.fc16 will be a downgrade
---> Package cups.x86_64 1:1.5.2-6.fc16 will be erased
---> Package cups-libs.i686 1:1.5.0-16.fc16 will be a downgrade
---> Package cups-libs.x86_64 1:1.5.0-16.fc16 will be a downgrade
---> Package cups-libs.i686 1:1.5.2-6.fc16 will be erased
---> Package cups-libs.x86_64 1:1.5.2-6.fc16 will be erased
--> Finished Dependency Resolution
...

How reproducible:
100% and can fix it with a downgrade

Steps to Reproduce:
1. yum update to latest
2. evince file.pdf
3. file>print   
  
Actual results:
Nothing there except "print to file"

Expected results:
A list of printers to choose from

Additional info:

Comment 1 Jiri Popelka 2012-04-11 07:46:09 UTC
Are the other packages of your system also updated ?

Could you please try with the latest test update?
# su -c 'yum update --enablerepo=updates-testing cups'

(This could be something similar to bug #807672 or bug #808109.)

Comment 2 Peter Glassenbury 2012-04-12 01:35:38 UTC
Sorry for the delay.. I couldn't check reliably from home last night or respond to bugzilla
Most of our systems are all packages updated...yum update 
is run nightly (the ones with the bug are definitely up to date
because I tried that to see if any updates were around. )
The two bugs you list don't seem to apply.. /tmp is OK
(unless there is something obscure in that bug-fix)

but the updates-testing packages DO FIX things and printing works :-)
The following is the complete cycle on another machine
Starting with 
F16 - initial install 
     cups x86_64 1:1.5.2-1.fc16
cups-libs x86_64 1:1.5.2-1.fc16
> evince file.pdf  # and print shows a list of printers

> yum check-updates
     cups.x86_64      1:1.5.2-6.fc16 updates                 
     cups-libs.x86_64 1:1.5.2-6.fc16 updates         
> yum update      # lots of updates including the two cups listed)
> evince file.pdf  # and print shows ONLY print to file (No printers)

> yum update --enablerepo=updates-testing cups 
     cups x86_64      1:1.5.2-8.1.fc16 updates-testing
     cups-libs x86_64 1:1.5.2-8.1.fc16 updates-testing
# wasn't sure if restart of cups needed so did that
> /bin/systemctl  restart cups.service
> evince file.pdf  # and print shows a list of printers

So the fix is done already :-)  Thanks
When will it move to updates release ?

Comment 3 Tim Waugh 2012-04-16 10:32:23 UTC

*** This bug has been marked as a duplicate of bug 807672 ***


Note You need to log in before you can comment on or make changes to this bug.