Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 811480 - headpin cli system command should display appropriate error
Summary: headpin cli system command should display appropriate error
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Subscription Asset Manager
Classification: Retired
Component: katello
Version: 1.0.0
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
: ---
Assignee: Eric Sammons
QA Contact: SAM QE List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-04-11 08:39 UTC by Tazim Kolhar
Modified: 2016-04-26 00:54 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-05-11 19:55:35 UTC


Attachments (Terms of Use)

Description Tazim Kolhar 2012-04-11 08:39:09 UTC
Description of problem:
headpin cli system subscriptions command requires --org and --name of
the system to be submitted . however if invalid values are supplied,
errors displayed are different.

Version-Release number of selected component (if applicable)
[root@ibm-hs22-03 ~]# rpm -qa katello-headpin
katello-headpin-0.1.145-1.el6.noarch

How reproducible:
yum install -y katello-headpin-all
katello-configure headpin.
headpin -u admin -p admin system --org <orgname> --name <systemname>


Steps to Reproduce:
1.yum install -y katello-headpin-all
2.katello-configure headpin.
3.headpin -u admin -p admin system --org <orgname> --name <systemname>

  
Actual results:
[root@ibm-hs22-03 ~]# headpin -u admin -p admin system list --org ACME_Corporation
--------------------------------------------------------------------------------
                   Systems List For Org [ ACME_Corporation ]

 Name                       
--------------------------------------------------------------------------------
 systemZp9c7JCgyvYNJ        
 kibSVLOd9LePP              
 Sj5Kwrfi33lh7np            
 iij15L8OU                  
 SearchSysfoRS2VLJQ7Eg5Lyv  
 SearchSysqWMfQuCASG        
 SearchSysN6e8kPRHYq7m      
 SearchSysqqtlMym6jG2j6Ms   
 2mrMjJL9DB2zrKzN           
 3R8O8TDSx                  
 jWRdwfhi7WL7hzXN           
 SearchSysjCNsL2pzJrs       
 SearchSysVXPOBopjTdyOqNo   
 SearchSysldlvQrhn          
 SearchSysZgmVLJ7m          
[root@ibm-hs22-03 ~]# headpin -u admin -p admin system subscriptions --org ACME_Corporation --name 3R8O8TDSx
--------------------------------------------------------------------------------
                 Current Subscriptions for System [ 3R8O8TDSx ]
--------------------------------------------------------------------------------

EntitlementId:     8aa2b6a23696102e0136970f3da003b1
Serial Id:         746114755679837731
PoolName:          High Touch Beta for Red Hat Enterprise Linux Server (8 sockets)
Expires:           2013-01-30
Consumed:          1
Quantity:          1
Sla:               
ContractNumber:    2828252
Provided products: Red Hat Enterprise Linux Server HTB

[root@ibm-hs22-03 ~]# headpin -u admin -p admin system subscriptions --name ACME_Corporation
Couldn't find organization 'testorg'

[root@ibm-hs22-03 ~]# headpin -u admin -p admin system subscriptions --name system123
Couldn't find organization 'testorg'



Expected results:
here,it should display error such as invalid system name or system does not
exists

Additional info:

Comment 2 RHEL Program Management 2012-04-11 08:44:16 UTC
Thank you for your bug report. This issue was evaluated for inclusion
in the current release of Subscription Asset Manager (SAM). Unfortunately,
we are unable to address this request. Because we are in the final stages
of development in the current release, only significant, release-blocking
issues involving serious regressions and data corruption can be considered.

If you believe this issue meets the release blocking criteria as defined and
communicated to you by your Red Hat Support representative, please ask
your representative to file this issue as a blocker for the current release.
Otherwise, ask that it be evaluated for inclusion in the next release of SAM.

Comment 3 RHEL Program Management 2012-04-11 09:04:16 UTC
Thank you for your bug report. This issue was evaluated for inclusion
in the current release of Subscription Asset Manager (SAM). Unfortunately,
we are unable to address this request. Because we are in the final stages
of development in the current release, only significant, release-blocking
issues involving serious regressions and data corruption can be considered.

If you believe this issue meets the release blocking criteria as defined and
communicated to you by your Red Hat Support representative, please ask
your representative to file this issue as a blocker for the current release.
Otherwise, ask that it be evaluated for inclusion in the next release of SAM.

Comment 4 Tom McKay 2012-04-30 14:33:33 UTC
What you're seeing here is due to a previously run 'client remember' command.

--Before "remember"--

katello> system subscriptions
Usage: katello [options]

katello: error: Option --name is required; please see --help
katello> system subscriptions --name foo
Could not find System [ foo ] in Org [ ACME_Corporation ]

--After "remember"--

katello> client remember --option org --value badorg
Successfully overwrote option [ org ] 
katello> system subscriptions --name foo
Couldn't find organization 'badorg'

In the code, before processing any of the arguments passed in the "remembered" options are checked first.

I would suggest this is not a bug.

Comment 5 Jordan OMara 2012-05-11 19:55:35 UTC
Closing, not a bug


Note You need to log in before you can comment on or make changes to this bug.