Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 81149 - Dell Lattitide C640 (radeon): LCD is on even when docked.
Dell Lattitide C640 (radeon): LCD is on even when docked.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
9
All Linux
medium Severity low
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
http://bugs.xfree86.org/cgi-bin/bugzi...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-01-06 01:40 EST by Aleksey Nogin
Modified: 2007-04-18 12:49 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-24 15:16:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aleksey Nogin 2003-01-06 01:40:18 EST
Both in 8.0 and in Phoebe, the LCD screen keeps working even when the lid is
closed and the laptop is docked, driving an external display. I am aware of the
"PanelOff" option, but it would not help if I want it to work correctly without
having to restart X every time I dock/undock.
Comment 1 Mike A. Harris 2003-01-18 05:15:01 EST
Probably best to report this upstream to xfree86@xfree86.org and/or the
dri-devel mailing lists.  This is more of a feature enhancement request
than a bug IMHO.  The "PanelOff" option exists more or less because the
feature you're requesting doesn't (to my knowledge anyway).  Such feature
would have to be implemented by someone on the XFree86 team with a similar
laptop.

I'll track this here nonetheless, so we're kept in the know of what types
of features are lacking.

It might be beneficial to attach your X server config file and log for
future reference.
Comment 2 Aleksey Nogin 2003-01-22 23:26:11 EST
Just filled the xfree bug report form on this issue.
Comment 3 Aleksey Nogin 2003-01-22 23:29:11 EST
P.S. See bug 81128 for relevant attachments.
Comment 4 Mike A. Harris 2003-01-24 01:50:25 EST
Closing as duplicate of 81128.  No sense tracking the same issue in two
or more separate bug reports.  Just update the other report as necessary
to reflect the current state of testing.

*** This bug has been marked as a duplicate of 81128 ***
Comment 5 Aleksey Nogin 2003-01-24 04:38:27 EST
I think you misunderstoon something - these are two completely different issues
found in a single setup.

This one is about a deficiency in the driver, but bug 81128 is about driver
behaving in a semi-reasonable way, but configuration tool not supporting it.

This one is about the internal LCD display, but bug 81128 is about the external
CRT display.

This bug also existed in Red Hat 8.0 (XFree86 4.2), the bug 81128 is specific to
the new radeon driver (that default to utilizing the "dual-head" features of the
card, while the 4.2 one was only capable of showing the same image (in the same
resolution) on both LCD and CRT.
Comment 6 Aleksey Nogin 2003-02-04 02:13:29 EST
I have to do some more testing (it is hard to see what's going on on LCD when
machine is docked and the lid is closed), but I suspect this might be fixed.
Comment 7 Aleksey Nogin 2003-05-19 19:07:55 EDT
This is likely to be related to
http://bugs.xfree86.org/cgi-bin/bugzilla/show_bug.cgi?id=26
Comment 8 Mike A. Harris 2004-09-24 15:16:39 EDT
We believe this issue to be resolved in Fedora Core 2.

Please upgrade to Fedora Core 2 or later, and if this issue turns
out to still be reproduceable, please file a bug report in the
X.Org bugzilla located at http://bugs.freedesktop.org in the
"xorg" component.

Once you've filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes
that become available for consideration in future updates.

Note You need to log in before you can comment on or make changes to this bug.