Bug 811503 - can't initiate voice/video call
can't initiate voice/video call
Product: Fedora
Classification: Fedora
Component: ktp-contact-list (Show other bugs)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jaroslav Reznik
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2012-04-11 05:40 EDT by Karel Volný
Modified: 2012-07-25 05:51 EDT (History)
5 users (show)

See Also:
Fixed In Version: ktp-call-ui-0.4.0-1.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2012-07-25 05:51:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Karel Volný 2012-04-11 05:40:55 EDT
Description of problem:
I am unable to call someone on jabber.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. configure a jabber account
2. choose some online contact that has audio/video capabilities
3. try to initiate audio or vide call from ktp-contactlist

Actual results:
the call is not initiated, in system messages you get this error:

Instant messaging

org.freedesktop.Telepathy.Error.NotAvailable: Handler no longer available

Expected results:
the call is initiated, no errors

Additional info:
this looks like Fedora specific issue ... if I try to call the Fedora user from Gentoo, I don't get such error on the Gentoo box, the call gets connected and we can speak
Comment 1 Martin Kho 2012-04-11 16:18:00 EDT

That's funny. The possibility to initiate an audio/video call is for me only available when I have Google+ in Chrome open. When I close Chrome these options are grayed out. Depends ktp/Telepathy on the Google-talkplugin?

Further [1] mentions ktp-call-ui as an optional application that "provides a voice/video chat window". Not sure if this is part of fedora's ktp and if it's needed for audio/video calls.

Martin Kho

[1] http://community.kde.org/Real-Time_Communication_and_Collaboration/Getting_Set_Up
Comment 2 Martin Kho 2012-04-11 16:21:04 EDT

BTW I have the following packages installed:


Martin Kho
Comment 3 Karel Volný 2012-04-17 07:23:43 EDT
(In reply to comment #1)
> Further [1] mentions ktp-call-ui as an optional application that "provides a
> voice/video chat window". Not sure if this is part of fedora's ktp and if it's
> needed for audio/video calls.

that one must be badly outdated ...

(stable version of) ktp-call-ui can't be even compiled for more than year I guess

so, actually, instead of using ktp-call-ui, the ktp-contact-list initiates the call using empathy-av

as for ktp-call-ui, it depends on some Qt telepathy farstream/farsight stuff which has some API issues (Qt vs Qt4 etc.) - a month (or two?) ago I've tried to fix these, posted a patch to our guys, but I was told that there already has been some effort to push the changes upstream which was rejected because they "plan" (oh, my ...) to do some bigger changes

... but I don't remember the case exactly - CCing Radek Nováček to provide more info
Comment 4 Radek Novacek 2012-04-24 07:50:05 EDT
According to blog of one of the Telepathy KDE authors, video calls should be in version 0.4.

Comment 5 Karel Volný 2012-04-24 08:38:12 EDT
(In reply to comment #4)
> According to blog of one of the Telepathy KDE authors, video calls should be in
> version 0.4.
> http://www.sharpley.org.uk/blog/kde-telepathy-in-0-4

thanks for the link, looks promising, however, will it make it into F17, or do we have to wait until F18?

... the blog is from March, it talks about April/May, it is end of April and still no signs that 0.4 would be getting ready

meanwhile, it'd be nice to have this one fixed - provided that this works for me on Gentoo (which doesn't seem to have any extra patches), this must be just some simple omission ... if only I knew where to look to see the difference and be able to suggest the fix :-/
Comment 6 Martin Klapetek 2012-07-23 05:19:53 EDT

the 0.3 version did not really support calls (it worked, but it was far from what we considered to be finished/releaseable), we were waiting for some upstream changes to be merged in and only after that we rewrote the calling component to take advantage of it and that all was released with 0.4 (which was considerably delayed...my apologies for that).

However a sneaky bug got into the ktp-call-ui, which sometimes prevents people from hearing the other side. This is already fixed and will be released with 0.4.1 these days.

Afaik the current version in f17 is 0.4, so you should already be able to do audio/video calls, can you please confirm?
Comment 7 Martin Kho 2012-07-23 06:33:29 EDT

For me ktp-call-ui is working in FC17 and rawhide.


Martin Kho
Comment 8 Karel Volný 2012-07-25 05:36:36 EDT
unfortunately, it doesn't quite work for me ...

I can call from machine A to machine B but not vice versa - if I try to call from machine B, it just opens a videocall window and says something like "connecting" forever, even if user from A disconnects completely, B still looks like trying to reach A

but A isn't without a problem too - it doesn't show video at all, neither from its own camera (and the options are grayed out) neither from B (which shows its camera output, but doesn't show anything from A - so the problem isn't just that it couldn't be displayed on A, but A also doesn't seem to trasmit anything)

both machines run fully updated F17

A is pure KDE (as much of GNOME removed as dependecies allow) while B has both KDE and GNOME installed

however, as I no longer receive the error message mentioned in the bug description, I'd consider this particular bug to be fixed ... I guess I'll wait for 0.4.1 then I'll open new bug(s) describing the actual behaviour if it still does not work well
Comment 9 Martin Klapetek 2012-07-25 05:51:55 EDT
Ok, thanks for reporting back.

I'll close this bug as fixed then, also feel free to open any bugs directly upstream where the whole KTp team can track it better - https://bugs.kde.org/enter_bug.cgi?product=telepathy&format=guided - component call-ui in this case ;)


Note You need to log in before you can comment on or make changes to this bug.