Bug 811529 - Unresolved dependency for rhc-rest
Unresolved dependency for rhc-rest
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
2.x
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Troy Dawson
libra bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-11 06:51 EDT by Alexander Todorov
Modified: 2015-05-14 21:50 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-08 13:59:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Todorov 2012-04-11 06:51:05 EDT
Description of problem:

Error: Package: rhc-rest-0.0.7-1.git.0.6ec063c.el6_2.noarch (openshift-express)
           Requires: rubygem-rest-client


Version-Release number of selected component (if applicable):
RHEL 6.2 i686
Comment 1 Xiaoli Tian 2012-04-11 08:38:08 EDT
That seems you do not enable your RHEL optional repo.
Comment 2 Alexander Todorov 2012-04-11 09:38:55 EDT
In RHN webUI I see the optional repository enabled:

Red Hat Enterprise Linux Workstation (v. 6 for 32-bit x86)
    RHN Tools for RHEL Workstation (v. 6 for 32-bit x86)
    RHEL Workstation Optional (v. 6 for 32-bit x86)
    RHEL Workstation Supplementary (v. 6 for 32-bit x86)
    RHEL Workstation FasTrack (v. 6 for 32-bit x86)
    RHEL Workstation Optional FasTrack (v. 6 for 32-bit x86)
Comment 3 Mike McGrath 2012-04-12 10:04:55 EDT
You actually need EPEL enabled.  I'll assign this ticket to tdawson so it gets pulled into brew so epel isn't needed.  Also lowering priority.
Comment 4 Troy Dawson 2012-04-12 15:20:09 EDT
I have succesfully build rubygem-rest-client-1.6.1-2 in brew for both RHEL6 and RHEL5
RHEL5 has the same issues.
I have them tagged so they should go out with this weeks sprint.
Comment 5 Troy Dawson 2012-04-16 17:53:35 EDT
The rubygem-rest-client has been released into the openshift repo with this latest release.  You should not need the epel repository to update to this latest release.
Comment 6 bzhao 2012-04-17 03:41:02 EDT
Passed verification against devenv 1724
Comment 7 Alexander Todorov 2012-04-17 12:16:19 EDT
Fails again for me with another error:

---> Package rubygem-rest-client.noarch 0:1.6.1-2.el6_2 will be installed
--> Processing Dependency: rubygem(mime-types) >= 1.16 for package: rubygem-rest-client-1.6.1-2.el6_2.noarch
--> Finished Dependency Resolution
Error: Package: rubygem-rest-client-1.6.1-2.el6_2.noarch (openshift-express)
           Requires: rubygem(mime-types) >= 1.16
Comment 8 bzhao 2012-04-20 03:44:55 EDT
It works well for my env(rhel5-u7_64 bit, rhel6.1-64_bit, rhel6.2-64_bit), rubygem-rest-client has been also released into the openshift repo, needn't the epel repo.

1. I think you should use the express repo file openshift.repo and then install the client tools

This is correct download URL https://openshift.redhat.com/app/repo/openshift.repo
Comment 9 Alexander Todorov 2012-04-20 04:46:17 EDT
My .repo file is the same: 

# cat openshift.repo 
[openshift-express]
name=Openshift Express
baseurl=https://openshift.redhat.com/app/repo/rpms/$releasever/$basearch/
failovermethod=priority
skip_if_unavailable=1
gpgkey=https://openshift.redhat.com/app/repo/RPM-GPG-KEY-redhat-beta
gpgkey=https://openshift.redhat.com/app/repo/RPM-GPG-KEY-redhat-release
enabled=1
gpgcheck=1


I'm on rhel6.2, 32bit. 

yum clean all && yum update - still fails:

--> Processing Dependency: rubygem(mime-types) >= 1.16 for package: rubygem-rest-client-1.6.1-2.el6_2.noarch
--> Finished Dependency Resolution
Error: Package: rubygem-rest-client-1.6.1-2.el6_2.noarch (openshift-express)
           Requires: rubygem(mime-types) >= 1.16
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


Where is rubygem(mime-types) dependency ?
Comment 10 Troy Dawson 2012-04-20 11:44:28 EDT
OK, so here is the full this of dependancies that came from epel and that we need in the openshift repository, so that a user doesn't have to use epel

rhc
rhc-rest
rubygem-json
rubygem-mime-types
rubygem-rest-client

The dependancies go this way

rhc -> rhc-rest and rubygem-json
rhc-rest -> rubygem-rest-client
rubygem-rest-client -> rubygem-mime-types

So we still need rubygem-json and rubygem-mime-types in the openshift repo.
I won't be able to get to that before the weekend, but I'll get them in there before we move to staging.
Comment 11 Troy Dawson 2012-04-23 13:04:57 EDT
Fixed for RHEL6 based systems.
I am now working on the RHEL5 based systems.
Comment 12 Troy Dawson 2012-05-16 17:50:38 EDT
So, RHEL5 was a little bit more work.  It requires the following

rhc
rubygems
rubygem-json
rubygem-mime-types
rubygem-parseconfig
rubygem-rake
rubygem-rest-client

These are all currently built for RHEL5, they are just waiting to be signed.
Comment 13 Troy Dawson 2012-05-17 15:38:51 EDT
This ticket is resolved for both RHEL6 and RHEL5.
You can now "yum install rhc" from the openshift repo, without EPEL, for both RHEL6 and RHEL5.
Comment 14 Meng Bo 2012-05-18 06:15:29 EDT
checked on latest openshift repo, still have some dependencies do not contain in it.

RHEL6.2_x86_64:
Installing:
 rhc                  noarch    0.92.11-1.el6_2     openshift-express 
Installing for dependencies:
 ruby-irb             x86_64    1.8.7.352-3.el6     rhel-source       
 ruby-rdoc            x86_64    1.8.7.352-3.el6     rhel-source-optional    
 rubygem-json         x86_64    1.4.6-7.el6         openshift-express 
 rubygem-mime-types   noarch    1.16-4.el6_0        openshift-express 
 rubygem-parseconfig  noarch    0.5.2-4.el6_0       openshift-express 
 rubygem-rake         noarch    0.8.7-2.1.el6       rhel-source-optional    
 rubygem-rest-client  noarch    1.6.1-2.el6_2       openshift-express 
 rubygems             noarch    1.3.7-1.el6         rhel-source-optional   


RHEL5.8_x86_64:
Installing:
 rhc                  noarch  0.92.11-1.el5      Openshift-express
Installing for dependencies:
 git                  x86_64  1.7.4.1-1.el5      epel               
 perl-Error           noarch  1:0.17010-1.el5    epel               
 perl-Git             x86_64  1.7.4.1-1.el5      epel               
 ruby-irb             x86_64  1.8.5-24.el5       rhel               
 ruby-rdoc            x86_64  1.8.5-24.el5       rhel               
 rubygem-json         x86_64  1.4.3-3.el5.1      epel               
 rubygem-mime-types   noarch  1.16-4.el5         Openshift-express  
 rubygem-parseconfig  noarch  0.5.2-4.el5        Openshift-express  
 rubygem-rake         noarch  0.8.7-2.el5        epel               
 rubygem-rest-client  noarch  1.6.1-2.el5        epel               
 rubygems             noarch  1.3.1-4.el5        Openshift-express
Comment 15 Troy Dawson 2012-05-18 09:51:56 EDT
Looks like I missed git, perl-Error and perl-Git for RHEL5.
Thanks for that catch.

But for testing, you need to do 

  "yum --disablerepo=epel install rhc"

I'll work on this next week.
Comment 16 Troy Dawson 2012-05-22 16:17:07 EDT
git took a bit more work than expected, but it's finolly built, just waiting for signatures.

git
asciidoc
perl-Devel-Symdump
perl-Error
perl-ExtUtils-CBuilder
perl-ExtUtils-ParseXS
perl-Module-Build
perl-Pod-Coverage
perl-Pod-Escapes
perl-Pod-Simple
perl-Test-Pod
perl-Test-Pod-Coverage
perl-YAML
Comment 17 Troy Dawson 2012-05-23 10:55:21 EDT
OK, I think we've got it this time.

You should now be able to install rhc on both RHEL6 and RHEL5 without using epel.

When testing please remember to disable the epel repository.

  yum --disablerepo=epel install rhc
Comment 18 Meng Bo 2012-05-24 02:26:36 EDT
verfied this bug on both RHEL-6.2 and RHEL-5.8
all the dependencies do not need epel repo now.

Note You need to log in before you can comment on or make changes to this bug.