Bug 811536 - Often get "execution expired" whille manipulating scalable apps
Often get "execution expired" whille manipulating scalable apps
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity low
: ---
: ---
Assigned To: Rob Millner
libra bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-11 07:07 EDT by jizhao
Modified: 2015-05-14 18:53 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-13 19:43:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jizhao 2012-04-11 07:07:00 EDT
Description of problem:
Often get "execution expired" while manipulating scalable apps, especially after adding several gears to it. Probably timeout.

Version-Release number of selected component (if applicable):
rhc-node-0.90.5-1.el6_2.x86_64
rubygem-stickshift-node-0.8.2-1.el6_2.noarch
rubygem-stickshift-controller-0.8.12-1.el6_2.noarch

How reproducible:
Often

Steps to Reproduce:
1.Create a scalable app
$ curl -k -H "Accept: application/xml" --user "jizhao+3@redhat.com:pas"  https://ec2-23-21-18-195.compute-1.amazonaws.com/broker/rest/domains/jizhao34/applications -X POST -d name=app1 -d cartridge=jbossas-7 -d scale=true
2.Scale it up
$ curl -k -H "Accept: application/xml" --user "<user>:<pass>"  https://<server_dns>/broker/rest/domains/<domain_name>/applications/<appname>/events -X POST -d event=scale-up
3.Embed mysql to it.
$ rhc app cartridge add -a <appname> -c mysql-5.1 -d
4.Destroy the app
  
Actual results:
Often get the following output on step3 and step4. Actually mysql is embedded successfully and app is destroyed successfully. Probably timeout.
<-------------------output------------------->
There was a problem communicating with the server. Response message: execution expired
If you were disconnected it is possible the operation finished without being able to report success.
You can use 'rhc domain show' and 'rhc app status' to learn about the status of your user and application(s).
<-------------------------------------------->

Expected results:
The client should be able to report the results.

Additional info:
Comment 1 Rob Millner 2012-06-19 19:41:52 EDT
I'm not able to reproduce this behaviour on devenv even after scaling up to 30 gears.  Was this on int or stg?
Comment 2 jizhao 2012-06-25 06:08:43 EDT
(In reply to comment #1)
> I'm not able to reproduce this behaviour on devenv even after scaling up to
> 30 gears.  Was this on int or stg?

It was on devenv. I've tested this bug on devenv_1893. It hardly happens now.
Changing the bug status to ON_QA.
Comment 3 jizhao 2012-06-25 22:38:57 EDT
According to comment 2, verify this bug.

Note You need to log in before you can comment on or make changes to this bug.