Bug 8116 - bogus html-helper-mode lines in emacs-20.4-5 site-start.el
Summary: bogus html-helper-mode lines in emacs-20.4-5 site-start.el
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: emacs   
(Show other bugs)
Version: 6.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-01-02 20:10 UTC by Jonathan Kamens
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-04 02:11:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jonathan Kamens 2000-01-02 20:10:49 UTC
The site-start.el file in emacs-20.4-5 has lines to load html-helper-mode
automatically when editing a *.html file.  The problem with this is that
html-helper-mode is not also included as part of the Emacs distribution,
which means that when I load a *.html file into Emacs, I get a file mode
specification error since Emacs can't load html-helper-mode.el.

I'll repeat here my previous complaint that it's obnoxious for an official
Emacs distribution to have all kinds of hacks in it which are not part of
standard Emacs.  Independent of that, if you insist on enabling
html-helper-mode in the RedHat emacs distribution, then you should include
html-helper-mode.el in the distribution.

Comment 1 Anonymous 2000-02-04 01:10:59 UTC
This bug doesn't seem to exist in emacs-20.5-2.


Note You need to log in before you can comment on or make changes to this bug.