Bug 811681 - Bluetooth mouse stops working because of "device file is duplicate. Ignoring." from evdev
Bluetooth mouse stops working because of "device file is duplicate. Ignoring....
Status: CLOSED DUPLICATE of bug 811534
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-evdev (Show other bugs)
16
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-11 13:32 EDT by Jonathan Briggs
Modified: 2012-04-19 21:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-19 21:38:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Briggs 2012-04-11 13:32:09 EDT
Description of problem:
The bluetooth mouse will stop working, apparently at random. It does not recover. Not even restarting the bluetooth service, or disconnecting and reconnecting the mouse fixes it in X.

The interesting thing is that doing a "cat /dev/input/mouse1" works perfectly. The mouse events are visible to the kernel.

In the /var/log/Xorg.0.log file, there are these messages whenever the mouse connection is reset:

[100147.444] (II) config/udev: Adding input device lynx’s mouse (/dev/input/mouse1)
[100147.444] (II) No input driver specified, ignoring this device.
[100147.444] (II) This device may have been added with another device file.
[100147.445] (II) config/udev: Adding input device lynx’s mouse (/dev/input/event13)
[100147.445] (**) lynx’s mouse: Applying InputClass "evdev pointer catchall"
[100147.445] (II) Using input driver 'evdev' for 'lynx’s mouse'
[100147.445] (II) Loading /usr/lib64/xorg/modules/input/evdev_drv.so
[100147.445] (**) lynx’s mouse: always reports core events
[100147.445] (**) evdev: lynx’s mouse: Device: "/dev/input/event13"
[100147.445] (WW) evdev: lynx’s mouse: device file is duplicate. Ignoring.
[100147.454] (EE) PreInit returned 8 for "lynx’s mouse"
[100147.454] (II) UnloadModule: "evdev"
[100147.454] (II) Unloading evdev


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Peter Hutterer 2012-04-19 21:31:52 EDT
full Xorg.log please.
Comment 2 Peter Hutterer 2012-04-19 21:38:27 EDT

*** This bug has been marked as a duplicate of bug 811534 ***

Note You need to log in before you can comment on or make changes to this bug.