Bug 811706 - fsck errors during install from livecd if system time is too far behind
fsck errors during install from livecd if system time is too far behind
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
: 812155 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-11 14:56 EDT by Tim Flink
Modified: 2013-05-10 17:51 EDT (History)
7 users (show)

See Also:
Fixed In Version: anaconda-17.21-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-10 17:51:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Flink 2012-04-11 14:56:48 EDT
If I do an install from a F17 beta RC4.1 livecd (desktop, x86_64) on a bare metal machine and that machine's system time is earlier than the livecd's creation time, I get fsck errors at the end of the install that halt the process and force me to reboot before the installation is actually complete.

e2fsck is run before the live image is resized to fit the disk it's being installed to. If the system time is before the last mount time of the live image, e2fsck fails and the installation stops.

I can produce logs if needed.
Comment 1 Chris Lumens 2012-04-15 13:43:51 EDT
*** Bug 812155 has been marked as a duplicate of this bug. ***
Comment 2 Fedora Update System 2012-04-18 20:22:52 EDT
anaconda-17.21-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/anaconda-17.21-1.fc17
Comment 3 Fedora Update System 2012-04-19 22:26:45 EDT
Package anaconda-17.21-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-17.21-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-6240/anaconda-17.21-1.fc17
then log in and leave karma (feedback).
Comment 4 Jan Teichmann 2012-11-12 09:02:08 EST
have the same problem with anaconda 17.29-1.fc17

ext4 filesystem check failure on /dev/mapper/vg_x60s-lv_root: 
File system errors left uncorrected.
Comment 5 Adam Williamson 2013-05-09 21:48:49 EDT
Tim: can you confirm whether this is fixed with current f17,f18,f19, whatever?
Comment 6 Tim Flink 2013-05-10 17:51:04 EDT
(In reply to comment #5)
> Tim: can you confirm whether this is fixed with current f17,f18,f19,
> whatever?

Interestingly enough, the F19 desktop livecd seems to be syncing time over network when a network connection is available. Not sure if the other spins are also doing this

I did an install using F19 alpha RC4 x86_64 desktop live (the newest live image I had on hand) and a system clock that was 3 years off, install went fine - closing the bug
Comment 7 Tim Flink 2013-05-10 17:51:53 EDT
(In reply to comment #6)
> (In reply to comment #5)
> > Tim: can you confirm whether this is fixed with current f17,f18,f19,
> > whatever?
> 
> Interestingly enough, the F19 desktop livecd seems to be syncing time over
> network when a network connection is available. Not sure if the other spins
> are also doing this
> 
> I did an install using F19 alpha RC4 x86_64 desktop live (the newest live
> image I had on hand) and a system clock that was 3 years off, install went
> fine - closing the bug

whoops, missing one detail - I disconnected the network for the install so that the time was not in sync at install time

Note You need to log in before you can comment on or make changes to this bug.