Bug 811754 - Process /usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/bin/java was killed by signal 6 (SIGABRT)
Process /usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/bin/java was kille...
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
16
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Alexander Kurtakov
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-11 17:59 EDT by Foampile
Modified: 2012-05-09 07:06 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-09 07:06:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
hs_err log file associated with the bug (60.21 KB, text/x-log)
2012-04-11 17:59 EDT, Foampile
no flags Details

  None (edit)
Description Foampile 2012-04-11 17:59:25 EDT
Created attachment 576903 [details]
hs_err log file associated with the bug

I get this error when trying to open the newly installed Eclipse Indigo.

I installed Eclipse by downloading the tar.gz and extracting it into /opt

Then I created an executable in /usr/bin and also a launcher in /user/share/applications

Eclipse splash opens where it lets me choose a workspace but then, when i pick one and hit OK, it crashed

the err log file is attached

thanks
Comment 1 Foampile 2012-04-12 02:03:07 EDT
the problem remains even after upgrading to Java 7 DEV JDK (yum install java-1.7.0-openjdk-devel.x86_64)
Comment 2 Alexander Kurtakov 2012-04-12 03:15:55 EDT
Your best bet is to do yum install eclipse . Upstream builds often crash because of incompatibility with newer versions of xulrunner. I see in your bug report that it's g_object_get_qdata call that fails but I cannot reproduce it. Let me know whether eclipse from rpm works fine for you.
Comment 3 Foampile 2012-04-12 16:45:45 EDT
Thanks, Alexander, however, the oddity is that this happened during an overhaul reinstall of my Fedora 16 system.  I previously had the same version of OS and Eclipse Indigo (albeit if could have been a different build).  I had installed it the same way (tar extraction, which is normally how Eclipse is installed, even on Windows).  What could have happened that some system update on top of the regular OS install could have broken it.
Comment 4 Foampile 2012-04-13 01:56:43 EDT
Alexander, i did as you suggested, installed it from yum (yum install eclipse-jdt), it installed version 3.7.1.  Unfortunately, the same error occurred.
Comment 5 Foampile 2012-04-13 02:15:53 EDT
I have a feeling the problem is within the kernel, I've tried different versions of both Eclipse as well as Java.  Do you see any issues in trying previous versions of the Kernel??
Comment 6 Foampile 2012-04-15 23:13:13 EDT
the solution suggested above did not do.  can we keep working on it?
Comment 7 Foampile 2012-04-16 03:27:40 EDT
I found this bug that is similar but the Linux distro is different:

https://bugs.eclipse.org/bugs/show_bug.cgi?id=317763
Comment 8 Foampile 2012-04-16 03:48:50 EDT
i forgot to mention this was in KDE

i logged  into GNOME -- Eclipse opened no problem

when i went back into KDE, the bug was gone.  i can now use Eclipse :)

so the problem is solved.  i still would like to know what was wrong.
Comment 9 Alexander Kurtakov 2012-05-09 07:06:06 EDT
Closing the bug as we can't find a way to reproduce. Please reopen if/when there are instructions how to reproduce.

Note You need to log in before you can comment on or make changes to this bug.