Bug 811784 - parted doesn't recognize the microsoft reserved partition type 0x0C01
parted doesn't recognize the microsoft reserved partition type 0x0C01
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: parted (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-11 21:03 EDT by joshua
Modified: 2012-06-05 13:58 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-05 13:58:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description joshua 2012-04-11 21:03:56 EDT
Description of problem:

gdisk enables you to enter any arbitrary GPT partition type 0x0C01.

parted doesn't.  If you need to partition and leave space for the microsoft reserved partition, how do you do this with parted?
Comment 1 joshua 2012-04-12 11:20:44 EDT
(parted) help mkpart
  mkpart PART-TYPE [FS-TYPE] START END     make a partition

	PART-TYPE is one of: primary, logical, extended
        FS-TYPE is one of: ext4, ext3, ext2, fat32, fat16, hfsx, hfs+, hfs, jfs,
        swsusp, linux-swap(v1), linux-swap(v0), ntfs, reiserfs, hp-ufs, sun-ufs,
        xfs, apfs2, apfs1, asfs, amufs5, amufs4, amufs3, amufs2, amufs1, amufs0,
        amufs, affs7, affs6, affs5, affs4, affs3, affs2, affs1, affs0,
        linux-swap, linux-swap(new), linux-swap(old)
        START and END are disk locations, such as 4GB or 10%.  Negative values
        count from the end of the disk.  For example, -1s specifies exactly the
        last sector.
        
        'mkpart' makes a partition without creating a new file system on the
        partition.  FS-TYPE may be specified to set an appropriate partition
        ID.



If parted is going to be the reason gdisk doesn't make it into the Anaconda installer and rescue image, could we please get basic functionality added to parted to make it usable?  We need *something* in the install/rescue image that understands the basics of GUID partitioning such that we can work with/around modern-day MS partition types
Comment 2 Brian Lane 2012-06-05 13:58:07 EDT
gdisk is included on the install images.

Note You need to log in before you can comment on or make changes to this bug.