Bug 811796 - Protected Custom Repo Names Not Propagated to guest rh-cloud.repo file.
Protected Custom Repo Names Not Propagated to guest rh-cloud.repo file.
Status: CLOSED ERRATA
Product: Red Hat Update Infrastructure for Cloud Providers
Classification: Red Hat
Component: Tools (Show other bugs)
2.1
x86_64 Linux
high Severity low
: ---
: 2.1.1
Assigned To: James Slagle
James Slagle
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-11 21:36 EDT by Matthew Mariani
Modified: 2013-02-27 11:58 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, yum displayed the unique numeric identifier for custom repositories. Repositories were not immediately identifiable because of this convention. The fix appends the custom repository name instead of the unique numeric identifier to the yum repository configuration.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-27 11:58:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0571 normal SHIPPED_LIVE Red Hat Update Infrastructure 2.1.1 bug fix update 2013-02-27 16:58:22 EST

  None (edit)
Description Matthew Mariani 2012-04-11 21:36:36 EDT
Description of problem:
yum update shows "random"? numeric identifier (10000,10002) for custom repo name instead of expected custom repo name.

rhui-cloud-rhel5-unprotected    | 2.3 kB     00:00
rhui-cloud-rhel5-unprotected/primary_db    | 1.2 kB     00:00
rhui-custom-10000 | 2.3 kB     00:00
rhui-custom-10000/primary_db           | 1.2 kB     00:00
rhui-custom-10002          | 2.3 kB     00:00
rhui-custom-10002/primary_db    | 1.2 kB     00:00
rhui-rhel-5-server-rhui-rpms    | 3.7 kB     00:00

Version-Release number of selected component (if applicable):
2.0.2

How reproducible:
Create custom repo, build and install an entitlement rpm, in the guest run a yum update.

Steps to Reproduce:
1. Create some protected repos on the RHUA
rhui (entitlements) => c
Custom Repository Entitlements
  For each entitlement URL listed, the corresponding repositories that are configured with that entitlement are listed. 

  cloud-generic-protected
    - Name: cloud-generic-protected
      URL:  cloud-generic-protected

  cloud-rhel6-protected
    - Name: cloud-rhel6-protected
      URL:  cloud-rhel6-protected

 cloud-rhel5-protected
    - Name: cloud-rhel5-protected
      URL:  cloud-rhel5-protected

2. Deploy an entitlement rpm including the protected custom repo

3. Do a yum update, observe "10000" instead of the expected repo name, view yum.repos.d/rh-cloud.repo

[root@v-ban1-rh58-64 ~]# yum check-update
Loaded plugins: katello, product-id, rhui-lb, security, subscription-manager
Updating certificate-based repositories.
Unable to read consumer identity
rhui-cloud-generic-unprotected                   | 2.3 kB     00:00
rhui-cloud-generic-uprotected/primary_db       | 1.2 kB     00:00
rhui-cloud-rhel5-unprotected    | 2.3 kB     00:00
rhui-cloud-rhel5-unprotected/primary_db    | 1.2 kB     00:00
rhui-custom-10000 | 2.3 kB     00:00
rhui-custom-10000/primary_db           | 1.2 kB     00:00   
rhui-custom-10002          | 2.3 kB     00:00
rhui-custom-10002/primary_db    | 1.2 kB     00:00
rhui-rhel-5-server-rhui-rpms    | 3.7 kB     00:00
rhui-rhel-5-server-rhui-rpms/primary_db     | 6.6 MB     00:00
Skipping security plugin, no data
  
Actual results:
above plus a yum.repos.d/rh-cloud.repo that shows:
[rhui-rhel-5-server-rhui-rpms]
name=Red Hat Enterprise Linux 5 Server from RHUI (RPMs)
mirrorlist=https://v-ban1-cds01.cloud.onx.com/pulp/mirror//content/dist/rhel/rhui/server/5/$releasever/$basearch/os
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-release
sslverify=1
sslcacert=/etc/pki/entitlement/ca.crt
sslclientcert=/etc/pki/entitlement/product/content.crt
sslclientkey=/etc/pki/entitlement/key.pem

[rhui-custom-10002]
name=Custom Repositories - 10002
mirrorlist=https://v-ban1-cds01.cloud.onx.com/pulp/mirror/cloud-rhel5-protected
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-release
sslverify=1
sslcacert=/etc/pki/entitlement/ca.crt
sslclientcert=/etc/pki/entitlement/product/content.crt
sslclientkey=/etc/pki/entitlement/key.pem


Expected results:
in rh-cloud.rep:
[rhui-custom-cloud-rhel5-protected]
name= Custom Repositories - cloud-rhel5-protected


Additional info:
Comment 1 wes hayutin 2012-07-30 16:11:23 EDT
moving to version 2.1.1
Comment 2 James Slagle 2012-11-30 09:52:59 EST
commit 4ba710642a2ee655e12b760a3b6740313ba8848a

One thing to note, since multiple custom repos might share the same entitlement path (custom repos just different by arch for example), we might not know which repo label to use in the yum config.  So, we just go with the first one repo for the entitlement path in question.
Comment 3 Vitaly Kuznetsov 2013-02-04 08:10:13 EST
# rpm -q rh-rhui-tools 
rh-rhui-tools-2.1.15-1.el6_3.noarch

On client:
# yum repolist | grep cp_1 && echo SUCCESS
Unable to read consumer identity
rhui-custom-cp_1                Custom Repositories - cp_1                0
Comment 5 errata-xmlrpc 2013-02-27 11:58:57 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0571.html

Note You need to log in before you can comment on or make changes to this bug.