Bug 811814 - live snapshot and mirroring should check whether target image is current one
live snapshot and mirroring should check whether target image is current one
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.3
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Jeff Cody
Virtualization Bugs
:
Depends On: 809140
Blocks: 806280
  Show dependency treegraph
 
Reported: 2012-04-11 23:21 EDT by Shaolong Hu
Modified: 2013-06-03 13:54 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-03 13:54:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shaolong Hu 2012-04-11 23:21:17 EDT
Description of problem:
------------------------
live snapshot and mirroring operation should check whether target image is current one.

Version-Release number of selected component (if applicable):
--------------------------------------------------------------
qemu-kvm 272

How reproducible:
------------------
100%

Steps to Reproduce:
--------------------
1. when live snapshot or mirroring, if target is current image using by the block device, they simply over write it instead of prompt error.

(qemu) info block
drive-virtio-disk0: removable=0 io-status=ok file=RHEL-Server-6.3-64-virtio.qcow2 ro=0 drv=qcow2 encrypted=0

(qemu) snapshot_blkdev drive-virtio-disk0 /root/RHEL-Server-6.3-64-virtio.qcow2


Expected results:
-------------------
prompt error and refuse to do so.
Comment 2 Jeff Cody 2012-04-12 15:53:06 EDT
Since we won't know if the path leading up to the snapshot filename matches exactly that path used to open the image, this will likely require something like realpath() or qemu_file_get_full_path(), so that we can compare absolute canonical filenames of all open images against the new proposed image filename.  Bug #809140 will likely bring qemu_file_get_full_path() in, so I am marking this dependent on that bug.

But even with a canonical absolute path, I don't think that gives us 100% protection - the file could still be located on a mounted network filesystem, under a different directory, etc. With that in mind, I am wondering if this is a bug we fix in the QEMU layer, or something that is on the management layer to be aware of (i.e. don't use an existing / open image).
Comment 5 RHEL Product and Program Management 2012-07-10 02:46:44 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 6 RHEL Product and Program Management 2012-07-10 22:05:54 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 7 Ademar Reis 2012-07-25 10:18:51 EDT
Due to limited capacity, we won't be able to work on this in RHEL6.4. Deferring to 6.5 (high chances of closing this as WONTFIX in the next cycle).
Comment 9 Ademar Reis 2013-06-03 13:54:49 EDT
(In reply to Ademar de Souza Reis Jr. from comment #7)
> Due to limited capacity, we won't be able to work on this in RHEL6.4.
> Deferring to 6.5 (high chances of closing this as WONTFIX in the next cycle).

Keeping my promisse...

Note You need to log in before you can comment on or make changes to this bug.