Bug 811818 - SELinux is preventing /usr/lib64/xulrunner-2/plugin-container from 'read' accesses on the chr_file /dev/bus/usb/001/009.
SELinux is preventing /usr/lib64/xulrunner-2/plugin-container from 'read' acc...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:0346c12f3005cc9cbb81eb2b323...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-12 00:53 EDT by Edward
Modified: 2012-04-18 19:07 EDT (History)
3 users (show)

See Also:
Fixed In Version: selinux-policy-3.10.0-116.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-18 19:07:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Edward 2012-04-12 00:53:13 EDT
libreport version: 2.0.10
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.3.1-3.fc17.x86_64
time:           Wed 11 Apr 2012 10:51:39 PM MDT

description:
:SELinux is preventing /usr/lib64/xulrunner-2/plugin-container from 'read' accesses on the chr_file /dev/bus/usb/001/009.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that plugin-container should be allowed read access on the 009 chr_file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep plugin-containe /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c
:                              0.c1023
:Target Context                system_u:object_r:usb_device_t:s0
:Target Objects                /dev/bus/usb/001/009 [ chr_file ]
:Source                        plugin-containe
:Source Path                   /usr/lib64/xulrunner-2/plugin-container
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           xulrunner-11.0-3.fc17.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-110.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Permissive
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.1-3.fc17.x86_64 #1 SMP Wed
:                              Apr 4 18:13:49 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    Wed 11 Apr 2012 10:50:39 PM MDT
:Last Seen                     Wed 11 Apr 2012 10:50:39 PM MDT
:Local ID                      31f35999-9472-4133-8b5b-1423c93ae671
:
:Raw Audit Messages
:type=AVC msg=audit(1334206239.661:339): avc:  denied  { read } for  pid=3721 comm="plugin-containe" name="009" dev="devtmpfs" ino=19148 scontext=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 tcontext=system_u:object_r:usb_device_t:s0 tclass=chr_file
:
:
:type=AVC msg=audit(1334206239.661:339): avc:  denied  { open } for  pid=3721 comm="plugin-containe" name="009" dev="devtmpfs" ino=19148 scontext=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 tcontext=system_u:object_r:usb_device_t:s0 tclass=chr_file
:
:
:type=SYSCALL msg=audit(1334206239.661:339): arch=x86_64 syscall=open success=yes exit=EXDEV a0=7fff2ec6cbc0 a1=0 a2=7fff2ec6cbd4 a3=378060b1a8 items=0 ppid=3667 pid=3721 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 tty=(none) ses=2 comm=plugin-containe exe=/usr/lib64/xulrunner-2/plugin-container subj=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 key=(null)
:
:Hash: plugin-containe,mozilla_plugin_t,usb_device_t,chr_file,read
:
:audit2allowunable to open /sys/fs/selinux/policy:  Permission denied
:
:
:audit2allow -Runable to open /sys/fs/selinux/policy:  Permission denied
:
:
Comment 1 Miroslav Grepl 2012-04-12 17:26:16 EDT
Do you know what you were doing when this happened?
Comment 2 Daniel Walsh 2012-04-13 12:14:22 EDT
Did you have mozplugger installed?
Comment 3 Edward 2012-04-16 00:01:02 EDT
The message came up when I plugged in my Garmin Forerunner 305 and tried to access it using garminplugin (http://www.andreas-diesner.de/garminplugin/doku.php?id=start).

@Daniel: No, I don't have mozplugger installed.  Should I?
Comment 4 Miroslav Grepl 2012-04-16 05:31:39 EDT
I am going to test it with my Garmin. Were you also trying to send a file to the device?
Comment 5 Daniel Walsh 2012-04-16 09:35:09 EDT
Edward, no,  mozplugger does not work with mozilla plugin confinement, since it runs apps like evince and libreoffice under the plugin.
Comment 6 Fedora Update System 2012-04-16 17:28:20 EDT
selinux-policy-3.10.0-116.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/selinux-policy-3.10.0-116.fc17
Comment 7 Fedora Update System 2012-04-18 19:07:37 EDT
selinux-policy-3.10.0-116.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.