Bug 811839 - cannot upload gz result if the result only contains one INFO test
cannot upload gz result if the result only contains one INFO test
Status: CLOSED CURRENTRELEASE
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Hardware Catalog (Show other bugs)
3.2
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Wei Shen
:
: 816679 (view as bug list)
Depends On:
Blocks: 733411
  Show dependency treegraph
 
Reported: 2012-04-12 01:33 EDT by Wei Shen
Modified: 2014-06-22 21:33 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-06 02:12:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 Wei Shen 2012-04-20 00:37:36 EDT
Created attachment 578863 [details]
the single INFO package
Comment 3 Wei Shen 2012-04-20 01:03:52 EDT
Created attachment 578866 [details]
the patch
Comment 4 Wei Shen 2012-04-23 01:35:25 EDT
verified on web2
Comment 5 Wei Shen 2012-04-27 02:10:57 EDT
vendor has met with this bug, need we make a package update with this patch?
Comment 6 Wei Shen 2012-04-27 04:09:00 EDT
*** Bug 816679 has been marked as a duplicate of this bug. ***
Comment 7 Wei Shen 2012-04-27 04:11:28 EDT
This can also be caused by only one INFO test in a single run.
Comment 8 Rob Landry 2012-04-27 10:11:57 EDT
(In reply to comment #5)
> vendor has met with this bug, need we make a package update with this patch?

The catalog shouldn't fault as it does above, it should either cleanly refuse the package as not helpful or accept the package and let it show as not helpful.  I suggest the latter.
Comment 9 Wei Shen 2012-04-27 22:34:56 EDT
(In reply to comment #8)
> (In reply to comment #5)
> > vendor has met with this bug, need we make a package update with this patch?
> 
> The catalog shouldn't fault as it does above, it should either cleanly refuse
> the package as not helpful or accept the package and let it show as not
> helpful.  I suggest the latter.

With this patch, no error would occur, catalog could accept the results as normal, this patch was applied on web2 already, it works well.
Comment 10 Wei Shen 2012-05-23 06:01:10 EDT
verified on partner

Note You need to log in before you can comment on or make changes to this bug.